summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/cantor/cantor-4.8.3.ebuild')
-rw-r--r--kde-base/cantor/cantor-4.8.3.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/kde-base/cantor/cantor-4.8.3.ebuild b/kde-base/cantor/cantor-4.8.3.ebuild
deleted file mode 100644
index c48b95612c8b..000000000000
--- a/kde-base/cantor/cantor-4.8.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.8.3.ebuild,v 1.5 2012/06/16 16:45:24 ssuominen Exp $
-
-EAPI=4
-
-KDE_HANDBOOK="optional"
-KDE_SCM="git"
-inherit kde4-base
-
-DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="analitza debug postscript +R"
-
-# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
-RDEPEND="
- analitza? ( $(add_kdebase_dep analitza) )
- postscript? ( app-text/libspectre )
- R? ( dev-lang/R )
-"
-DEPEND="${RDEPEND}
- >=dev-cpp/eigen-2.0.3:2
-"
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with analitza)
- $(cmake-utils_use_with postscript LibSpectre)
- $(cmake-utils_use_with R)
- )
- kde4-base_src_configure
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- if ! use R; then
- echo
- ewarn "You have decided to build ${PN} with no backend."
- ewarn "To have this application functional, please do one of below:"
- ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
- ewarn " # emerge -vaDu sci-mathematics/maxima"
- echo
- fi
-}