summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kate/kate-4.4.3.ebuild')
-rw-r--r--kde-base/kate/kate-4.4.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-base/kate/kate-4.4.3.ebuild b/kde-base/kate/kate-4.4.3.ebuild
new file mode 100644
index 000000000000..f88b8a8f4ca1
--- /dev/null
+++ b/kde-base/kate/kate-4.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.4.3.ebuild,v 1.1 2010/05/03 20:20:21 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}