summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kcheckpass/kcheckpass-4.3.0.ebuild')
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/kcheckpass/kcheckpass-4.3.0.ebuild b/kde-base/kcheckpass/kcheckpass-4.3.0.ebuild
new file mode 100644
index 000000000000..4fe84f09fe74
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.3.0.ebuild,v 1.1 2009/08/04 00:00:05 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug pam"
+
+DEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/kdebase-4.0.2-pam-optional.patch" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with pam)"
+
+ kde4-meta_src_configure
+}