summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdebindings/kdebindings-3.1_beta2.ebuild')
-rw-r--r--kde-base/kdebindings/kdebindings-3.1_beta2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild b/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild
new file mode 100644
index 000000000000..7c85b95f7d24
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild,v 1.1 2002/10/02 19:20:10 danarmak Exp $
+# TODO: add gnustep, objc bindings
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - kde library bindings for languages other than c++"
+
+KEYWORDS="x86"
+
+newdepend "~kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ ~kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+#src_unpack()
+#{
+# base_src_unpack
+#
+# if [ -z "`use mozilla`" ]; then
+# # disable mozilla bindings/xpart
+# cd ${S}
+# cp configure configure.orig
+# sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+# chmod +x configure
+# fi
+#}
+