summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog6
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.3.4.ebuild14
2 files changed, 12 insertions, 8 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index 9c108019a094..9f376bc8e1f0 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.44 2009/12/10 20:29:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.45 2009/12/23 00:05:00 abcd Exp $
+
+ 23 Dec 2009; Jonathan Callen <abcd@gentoo.org>
+ kdeplasma-addons-4.3.4.ebuild:
+ Pull in changes from overlay and prefix support
10 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org>
-kdeplasma-addons-4.3.1.ebuild:
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.3.4.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.3.4.ebuild
index 197727788923..0d4f70cd0ec1 100644
--- a/kde-base/kdeplasma-addons/kdeplasma-addons-4.3.4.ebuild
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.3.4.ebuild,v 1.1 2009/12/01 10:27:58 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.3.4.ebuild,v 1.2 2009/12/23 00:05:00 abcd Exp $
EAPI="2"
@@ -17,7 +17,7 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug desktopglobe exif semantic-desktop"
# krunner is only needed to generate dbus interface for lancelot
-COMMON_DEPEND="
+RDEPEND="
$(add_kdebase_dep kdelibs 'opengl?,semantic-desktop?')
$(add_kdebase_dep kdepimlibs)
$(add_kdebase_dep krunner)
@@ -26,10 +26,9 @@ COMMON_DEPEND="
desktopglobe? ( $(add_kdebase_dep marble) )
exif? ( $(add_kdebase_dep libkexiv2) )
"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${RDEPEND}
dev-cpp/eigen:2
"
-RDEPEND="${COMMON_DEPEND}"
# kdebase-data: some svg icons moved from data directly here.
add_blocker kdebase-data '<4.2.88'
@@ -49,12 +48,13 @@ src_prepare() {
}
src_configure() {
- mycmakeargs="${mycmakeargs}
- -DDBUS_INTERFACES_INSTALL_DIR=${KDEDIR}/share/dbus-1/interfaces/
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EKDEDIR}/share/dbus-1/interfaces/"
$(cmake-utils_use_with exif Kexiv2)
$(cmake-utils_use_with desktopglobe Marble)
$(cmake-utils_use_with opengl OpenGL)
- $(cmake-utils_use_with semantic-desktop Nepomuk)"
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
kde4-base_src_configure
}