summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdesdk/kdesdk-3.4.3.ebuild')
-rw-r--r--kde-base/kdesdk/kdesdk-3.4.3.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/kde-base/kdesdk/kdesdk-3.4.3.ebuild b/kde-base/kdesdk/kdesdk-3.4.3.ebuild
deleted file mode 100644
index ec3fa8f4304c..000000000000
--- a/kde-base/kdesdk/kdesdk-3.4.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.4.3.ebuild,v 1.8 2006/06/11 15:58:08 genstef Exp $
-
-inherit kde-dist eutils
-
-DESCRIPTION="KDE SDK: Cervisia, KBabel, KCachegrind, Kompare, Umbrello,..."
-
-KEYWORDS="amd64 hppa ppc sparc x86"
-IUSE="berkdb subversion"
-
-DEPEND="x86? ( || ( >=dev-util/valgrind-3.2.0
- dev-util/callgrind ) )
- subversion? ( dev-util/subversion )
- berkdb? ( || ( =sys-libs/db-4.3*
- =sys-libs/db-4.2* ) )"
-
-RDEPEND="${DEPEND}
- dev-util/cvs
- media-gfx/graphviz"
-
-src_unpack() {
- kde_src_unpack
-
- # Configure patch. Applied for 3.5.
- epatch "${FILESDIR}/kdesdk-3.4-configure.patch"
-
- # For the configure patch.
- make -f admin/Makefile.common || die
-}
-
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-src_compile() {
- local myconf="$(use_with subversion)"
-
- if use berkdb; then
- if has_version "=sys-libs/db-4.3*"; then
- myconf="${myconf} --with-berkeley-db --with-db-name=db-4.3
- --with-db-include-dir=/usr/include/db4.3"
- elif has_version "=sys-libs/db-4.2*"; then
- myconf="${myconf} --with-berkeley-db --with-db-name=db-4.2
- --with-db-include-dir=/usr/include/db4.2"
- fi
- else
- myconf="${myconf} --without-berkeley-db"
- fi
-
- kde_src_compile
-}