summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kget/kget-4.9.2.ebuild')
-rw-r--r--kde-base/kget/kget-4.9.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/kget/kget-4.9.2.ebuild b/kde-base/kget/kget-4.9.2.ebuild
new file mode 100644
index 000000000000..2c2ea9be9c75
--- /dev/null
+++ b/kde-base/kget/kget-4.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kget/kget-4.9.2.ebuild,v 1.1 2012/10/02 18:11:59 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdenetwork"
+KDE_SCM="svn"
+inherit kde4-meta
+
+DESCRIPTION="An advanced download manager for KDE"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bittorrent mms semantic-desktop sqlite webkit"
+
+RDEPEND="
+ app-crypt/qca:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep libkonq)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep solid)
+ bittorrent? ( >=net-libs/libktorrent-1.0.3 )
+ mms? ( media-libs/libmms )
+ sqlite? ( dev-db/sqlite:3 )
+ webkit? ( >=kde-misc/kwebkitpart-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bittorrent KTorrent)
+ $(cmake-utils_use_with mms LibMms)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with sqlite)
+ $(cmake-utils_use_with webkit KWebKitPart)
+ )
+ kde4-meta_src_configure
+}