summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kgpg/kgpg-3.5.10.ebuild')
-rw-r--r--kde-base/kgpg/kgpg-3.5.10.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/kde-base/kgpg/kgpg-3.5.10.ebuild b/kde-base/kgpg/kgpg-3.5.10.ebuild
index 800b3af967e6..2e2aaa918d64 100644
--- a/kde-base/kgpg/kgpg-3.5.10.ebuild
+++ b/kde-base/kgpg/kgpg-3.5.10.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/kgpg-3.5.10.ebuild,v 1.7 2009/07/12 10:28:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/kgpg-3.5.10.ebuild,v 1.8 2009/10/13 17:03:04 ssuominen Exp $
KMNAME=kdeutils
-EAPI="1"
+EAPI="2"
inherit kde-meta eutils
DESCRIPTION="KDE gpg keyring manager"
@@ -12,14 +12,4 @@ IUSE="kdehiddenvisibility"
RDEPEND="${RDEPEND}
app-crypt/gnupg
- app-crypt/pinentry"
-
-pkg_setup() {
- if ! built_with_use app-crypt/pinentry gtk && ! built_with_use app-crypt/pinentry qt3 ; then
- eerror "${PN} needs app-crypt/pinentry built with either the gtk or qt3 USE flag."
- eerror "Please enable either USE flag and re-install app-crypt/pinentry."
- die "app-crypt/pinentry needs to be rebuilt with gtk or qt3 support."
- fi
-
- kde_pkg_setup
-}
+ || ( app-crypt/pinentry[qt3] app-crypt/pinentry[gtk] )"