summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kigo')
-rw-r--r--kde-base/kigo/ChangeLog7
-rw-r--r--kde-base/kigo/kigo-4.9.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kigo/ChangeLog b/kde-base/kigo/ChangeLog
index 2fb8468cbbd9..82a87713add8 100644
--- a/kde-base/kigo/ChangeLog
+++ b/kde-base/kigo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kigo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kigo/ChangeLog,v 1.81 2012/10/02 18:11:58 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kigo/ChangeLog,v 1.82 2012/11/08 23:26:46 creffett Exp $
+
+*kigo-4.9.3 (08 Nov 2012)
+
+ 08 Nov 2012; <creffett@gentoo.org> +kigo-4.9.3.ebuild:
+ Version bump KDE SC 4.9.3
*kigo-4.9.2 (02 Oct 2012)
diff --git a/kde-base/kigo/kigo-4.9.3.ebuild b/kde-base/kigo/kigo-4.9.3.ebuild
new file mode 100644
index 000000000000..591f539d7f5d
--- /dev/null
+++ b/kde-base/kigo/kigo-4.9.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kigo/kigo-4.9.3.ebuild,v 1.1 2012/11/08 23:26:46 creffett Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]]; then
+ eclass="kde4-base"
+else
+ eclass="kde4-meta"
+ KMNAME="kdegames"
+fi
+KDE_HANDBOOK="optional"
+inherit games-ggz ${eclass}
+
+DESCRIPTION="KDE Go game"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ games-board/gnugo
+"
+
+src_install() {
+ ${eclass}_src_install
+ # and also we have to prepare the ggz dir
+ insinto "${GGZ_MODDIR}"
+ if [[ ${PV} == *9999 ]]; then
+ newins src/module.dsc ${P}.dsc
+ else
+ newins ${PN}/src/module.dsc ${P}.dsc
+ fi
+}
+
+pkg_postinst() {
+ ${eclass}_pkg_postinst
+ games-ggz_pkg_postinst
+}
+
+pkg_postrm() {
+ ${eclass}_pkg_postrm
+ games-ggz_pkg_postrm
+}