summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kimono/kimono-4.8.5.ebuild')
-rw-r--r--kde-base/kimono/kimono-4.8.5.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/kde-base/kimono/kimono-4.8.5.ebuild b/kde-base/kimono/kimono-4.8.5.ebuild
deleted file mode 100644
index 2ae1d9f083f7..000000000000
--- a/kde-base/kimono/kimono-4.8.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.8.5.ebuild,v 1.4 2012/09/03 12:20:22 scarabeus Exp $
-
-EAPI=4
-
-KDE_SCM="git"
-inherit kde4-base mono
-
-DESCRIPTION="C# bindings for KDE"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="akonadi debug plasma semantic-desktop"
-
-DEPEND="
- dev-lang/mono
- $(add_kdebase_dep qyoto 'webkit')
- $(add_kdebase_dep smokeqt)
- $(add_kdebase_dep smokekde 'semantic-desktop=')
- plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
- semantic-desktop? ( >=dev-libs/soprano-2.7.6[clucene] )
-"
-RDEPEND="${DEPEND}"
-
-# Split from kdebindings-csharp in 4.7
-add_blocker kdebindings-csharp
-
-src_prepare() {
- kde4-base_src_prepare
-
- sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
-}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with akonadi)
- $(cmake-utils_use_with akonadi KdepimLibs)
- $(cmake-utils_use_disable plasma)
- $(cmake-utils_use_with semantic-desktop Nepomuk)
- $(cmake-utils_use_with semantic-desktop Soprano)
- )
- kde4-base_src_configure
-}