summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kmail/kmail-4.4.10.ebuild')
-rw-r--r--kde-base/kmail/kmail-4.4.10.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/kde-base/kmail/kmail-4.4.10.ebuild b/kde-base/kmail/kmail-4.4.10.ebuild
new file mode 100644
index 000000000000..a60adbaa7f7b
--- /dev/null
+++ b/kde-base/kmail/kmail-4.4.10.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.4.10.ebuild,v 1.1 2011/01/28 05:17:40 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdepim"
+VIRTUALX_REQUIRED=tests
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep libkdepim)
+ $(add_kdebase_dep libkleo)
+ $(add_kdebase_dep libkpgp)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+add_blocker kmailcvt
+add_blocker libksieve
+add_blocker messagecore
+add_blocker messagelist
+add_blocker messageviewer
+add_blocker mimelib
+
+KMEXTRACTONLY="
+ korganizer/org.kde.Korganizer.Calendar.xml
+ libkleo/
+ libkpgp/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ messagecore/
+ messagelist/
+ messageviewer/
+ mimelib/
+ plugins/kmail/
+"
+KMLOADLIBS="libkdepim"
+
+PATCHES=( "${FILESDIR}/${P}"-nodbus.patch )
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ mycmakeargs=(
+ -DWITH_IndicateQt=OFF
+ )
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}