summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/korundum/korundum-3.4.0.ebuild')
-rw-r--r--kde-base/korundum/korundum-3.4.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/korundum/korundum-3.4.0.ebuild b/kde-base/korundum/korundum-3.4.0.ebuild
new file mode 100644
index 000000000000..fbf1b6dc4376
--- /dev/null
+++ b/kde-base/korundum/korundum-3.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-3.4.0.ebuild,v 1.1 2005/03/13 21:19:08 danarmak Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt libsmokekde smoke/kde"
+KMCOMPILEONLY="qtruby"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE ruby bindings"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+
+KEYWORDS="~x86"
+IUSE=""
+OLDDEPEND=">=virtual/ruby-1.8 ~kde-base/qtruby-$PV ~kde-base/smoke-3.3.1"
+DEPEND=" >=virtual/ruby-1.8
+$(deprange $PV $MAXKDEVER kde-base/qtruby)
+$(deprange $PV $MAXKDEVER kde-base/smoke)"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke and qtruby versions.
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}
+