summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.5.4.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index ff8c3333cd08..6c402b6a9615 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.176 2010/11/03 16:30:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.177 2010/12/02 21:15:05 alexxy Exp $
+
+*kstars-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> +kstars-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
*kstars-4.5.3 (03 Nov 2010)
diff --git a/kde-base/kstars/kstars-4.5.4.ebuild b/kde-base/kstars/kstars-4.5.4.ebuild
new file mode 100644
index 000000000000..566503b91331
--- /dev/null
+++ b/kde-base/kstars/kstars-4.5.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.5.4.ebuild,v 1.1 2010/12/02 21:15:05 alexxy Exp $
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug fits indi"
+
+DEPEND="
+ $(add_kdebase_dep libkdeedu)
+ fits? ( >=sci-libs/cfitsio-0.390 )
+ indi? ( >=sci-libs/indilib-0.6.2[fits?] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.65-solaris.patch
+)
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ mycmakeargs=(
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with indi)
+ )
+
+ kde4-meta_src_configure
+}