summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkonq/libkonq-4.0.1.ebuild')
-rw-r--r--kde-base/libkonq/libkonq-4.0.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/kde-base/libkonq/libkonq-4.0.1.ebuild b/kde-base/libkonq/libkonq-4.0.1.ebuild
new file mode 100644
index 000000000000..e4dc62706b2f
--- /dev/null
+++ b/kde-base/libkonq/libkonq-4.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkonq/libkonq-4.0.1.ebuild,v 1.1 2008/02/07 00:12:00 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase
+KMMODULE=apps/lib/konq
+inherit kde4-meta
+
+DESCRIPTION="The embeddable part of konqueror"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+src_test() {
+ # three out of four tests are broken. we just disable those. last tested on 4.0.1.
+ sed -e "/konqpopupmenutest/s/^/#DONOTTEST /" \
+ -e "/konqfileundomanagertest/s/^/#DONOTTEST /" \
+ -e "/favicontest/s/^/#DONOTTEST /" \
+ -i "${S}"/apps/lib/konq/tests/CMakeLists.txt
+ kde4-base_src_test
+}