summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kfilebox/kfilebox-0.4.7.ebuild')
-rw-r--r--kde-misc/kfilebox/kfilebox-0.4.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-misc/kfilebox/kfilebox-0.4.7.ebuild b/kde-misc/kfilebox/kfilebox-0.4.7.ebuild
new file mode 100644
index 000000000000..728cdbac20c5
--- /dev/null
+++ b/kde-misc/kfilebox/kfilebox-0.4.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kfilebox/kfilebox-0.4.7.ebuild,v 1.1 2011/09/11 10:16:14 tampakrap Exp $
+
+EAPI=4
+
+LANGS="ar br cs de el es fr gl it lt nl pl pt ru si tr zh zh_CN"
+inherit qt4-r2
+
+DESCRIPTION="KDE dropbox client"
+HOMEPAGE="http://kdropbox.deuteros.es/"
+SRC_URI="mirror://sourceforge/kdropbox/${P}.tar.gz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+for name in ${LANGS} ; do IUSE+="linguas_$name " ; done
+unset name
+
+DEPEND="kde-base/kdelibs"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ qt4-r2_src_install
+
+ for lang in ${LANGS}; do
+ if ! has ${lang} ${LINGUAS}; then
+ rm -rf "${D}"/usr/share/locale/${lang} || die
+ fi
+ done
+}