summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/geary/files/geary-0.5.0-unity.patch')
-rw-r--r--mail-client/geary/files/geary-0.5.0-unity.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/mail-client/geary/files/geary-0.5.0-unity.patch b/mail-client/geary/files/geary-0.5.0-unity.patch
new file mode 100644
index 000000000000..837b37f372ad
--- /dev/null
+++ b/mail-client/geary/files/geary-0.5.0-unity.patch
@@ -0,0 +1,31 @@
+commit 1f875e8a629a54748eb46237fd854359aa5edbc8
+Author: hasufell <hasufell@gentoo.org>
+Date: Tue Aug 27 01:40:45 2013 +0200
+
+ provide option for unity
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 66145c9..5d4464c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,6 +32,7 @@
+ option(ICON_UPDATE "Run gtk-update-icon-cache after the install." ON)
+ option(DESKTOP_UPDATE "Run update-desktop-database after the install." ON)
+ option(DESKTOP_VALIDATE "Check generated desktop file for errors during build." ON)
++option(WITH_UNITY "Add unity support." OFF)
+
+ if (DEBUG)
+ message(STATUS "Debug build")
+@@ -50,8 +51,10 @@
+ endif ()
+
+ find_package(PkgConfig)
+-pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
+-pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
++if (WITH_UNITY)
++ pkg_check_modules(LIBUNITY QUIET unity>=5.12.0)
++ pkg_check_modules(LIBMESSAGINGMENU QUIET messaging-menu>=12.10.2)
++endif ()
+ pkg_check_modules(WEBKITGTK110X QUIET webkitgtk-3.0<=1.10.2)
+ pkg_check_modules(WEBKITGTK22X QUIET webkitgtk-3.0>=2.2.0)
+