summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/anubis/ChangeLog11
-rw-r--r--mail-filter/anubis/Manifest12
-rw-r--r--mail-filter/anubis/anubis-3.9.95.ebuild81
-rw-r--r--mail-filter/anubis/files/3.9.95-authmode.c.patch11
-rw-r--r--mail-filter/anubis/files/3.9.95-transmode.c.patch12
-rw-r--r--mail-filter/anubis/files/digest-anubis-3.9.951
6 files changed, 123 insertions, 5 deletions
diff --git a/mail-filter/anubis/ChangeLog b/mail-filter/anubis/ChangeLog
index f3bef4c1fd5f..02d7559edd9b 100644
--- a/mail-filter/anubis/ChangeLog
+++ b/mail-filter/anubis/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-filter/anubis
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/anubis/ChangeLog,v 1.3 2004/07/18 15:40:35 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/anubis/ChangeLog,v 1.4 2004/09/08 19:45:29 ticho Exp $
+
+*anubis-3.9.95 (08 Sep 2004)
+
+ 08 Sep 2004; Andrej Kacian <ticho@gentoo.org>
+ +files/3.9.95-authmode.c.patch, +files/3.9.95-transmode.c.patch,
+ +anubis-3.9.95.ebuild:
+ Version bump. Closes #59850, reported by Daniel Black
+ <dragonheart@gentoo.org>, who also provided two patches applied to source by
+ the ebuild.
*anubis-3.6.2 (03 Jun 2004)
diff --git a/mail-filter/anubis/Manifest b/mail-filter/anubis/Manifest
index 7add432022ca..50f135cd39ef 100644
--- a/mail-filter/anubis/Manifest
+++ b/mail-filter/anubis/Manifest
@@ -1,7 +1,11 @@
-MD5 3c698e8a3f7f59300484418a07756c08 anubis-3.6.2.ebuild 975
-MD5 04e61ab39618ff33b8e098b30ab1416b anubis-3.6.2-r1.ebuild 1076
MD5 c3744646a43ddfa721582870a4324bb0 ChangeLog 1049
+MD5 04e61ab39618ff33b8e098b30ab1416b anubis-3.6.2-r1.ebuild 1076
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
-MD5 24def86bd1cfb613e6c0dcf55194d449 files/digest-anubis-3.6.2 64
-MD5 a345a52e49034f67fe700e0464804933 files/3.6.2-secfixes.patch.gz 1455
+MD5 9e1ce31289cd1fd3218f26f2c7e9efd8 anubis-3.9.95.ebuild 1835
+MD5 3c698e8a3f7f59300484418a07756c08 anubis-3.6.2.ebuild 975
+MD5 cc4ec1af9779d9945e617204d549a19f files/3.9.95-transmode.c.patch 321
+MD5 b2320df43592e63e327683a3e82928b1 files/3.9.95-authmode.c.patch 438
MD5 24def86bd1cfb613e6c0dcf55194d449 files/digest-anubis-3.6.2-r1 64
+MD5 82fb55fcc52a9af0d23fc2085979e467 files/digest-anubis-3.9.95 65
+MD5 a345a52e49034f67fe700e0464804933 files/3.6.2-secfixes.patch.gz 1455
+MD5 24def86bd1cfb613e6c0dcf55194d449 files/digest-anubis-3.6.2 64
diff --git a/mail-filter/anubis/anubis-3.9.95.ebuild b/mail-filter/anubis/anubis-3.9.95.ebuild
new file mode 100644
index 000000000000..9796bca534d5
--- /dev/null
+++ b/mail-filter/anubis/anubis-3.9.95.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/anubis/anubis-3.9.95.ebuild,v 1.1 2004/09/08 19:45:29 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="GNU Anubis is an outgoing mail processor."
+HOMEPAGE="http://www.gnu.org/software/anubis/"
+
+SRC_URI="ftp://mirddin.farlep.net/pub/alpha/anubis/${P}.tar.gz"
+
+# Hasn't propergated much at time of commit.
+# SRC_URI="mirror://gnu/anubis/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="crypt dbm guile mysql postgres nls pam pcre sasl socks5 ssl tcpd"
+
+DEPEND="crypt? ( >=app-crypt/gpgme-0.9.0 )
+ dbm? ( sys-libs/gdbm )
+ guile? ( >=dev-util/guile-1.6 )
+ mysql? ( dev-db/mysql )
+ pam? ( >=sys-libs/pam-0.75 )
+ postgres? ( dev-db/postgresql )
+ nls? ( sys-devel/gettext )
+ pcre? ( >=dev-libs/libpcre-3.9 )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-misc/dante )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+# has gnutls=1.0.0 option that is incompatible with ssl
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-transmode.c.patch
+ epatch ${FILESDIR}/${PV}-authmode.c.patch
+}
+
+src_compile() {
+ local myconf="--with-unprivileged-user=anubis"
+
+ use crypt || myconf="${myconf} --without-gpgme"
+ if [ -x ${ROOT}/usr/bin/gpg2 ];
+ then
+ GPG=${ROOT}/usr/bin/gpg2
+ else
+ GPG=${ROOT}/usr/bin/gpg
+ fi
+
+ use ssl && myconf="${myconf} --with-openssl"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use sock5 && myconf="${myconf} --with-socks-proxy"
+
+ econf ${myconf} `use_with mysql` `use_with postgres` \
+ `use_with pam` `use_with pcre` `use_with nls` \
+ `use_with guile` `use_with dbm` `use_with sasl gsasl` \
+ || die
+
+ emake -j1 || die
+ # parallel make fails in testsuite
+}
+
+pkg_setup() {
+ enewuser anubis
+}
+
+pkg_preinst() {
+ enewuser anubis
+}
+
+src_test() {
+ cd ${S}/testsuite
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR=${D} install
+}
diff --git a/mail-filter/anubis/files/3.9.95-authmode.c.patch b/mail-filter/anubis/files/3.9.95-authmode.c.patch
new file mode 100644
index 000000000000..b2c745c6b2fa
--- /dev/null
+++ b/mail-filter/anubis/files/3.9.95-authmode.c.patch
@@ -0,0 +1,11 @@
+--- src/authmode.c.orig 2004-08-29 16:37:43.050245536 +0930
++++ src/authmode.c 2004-08-29 16:37:57.351751200 +0930
+@@ -619,7 +619,7 @@
+ info (NORMAL, _("Connection closed successfully."));
+
+ #ifdef HAVE_PAM
+- pam_retval = pam_close_session (pamh, 0);
++ int pam_retval = pam_close_session (pamh, 0);
+ if (pam_retval == PAM_SUCCESS)
+ info (VERBOSE, _("PAM: Session closed."));
+ if (pam_end (pamh, pam_retval) != PAM_SUCCESS)
diff --git a/mail-filter/anubis/files/3.9.95-transmode.c.patch b/mail-filter/anubis/files/3.9.95-transmode.c.patch
new file mode 100644
index 000000000000..08f329dbb541
--- /dev/null
+++ b/mail-filter/anubis/files/3.9.95-transmode.c.patch
@@ -0,0 +1,12 @@
+--- src/transmode.c.orig 2004-08-29 15:17:31.818177248 +0930
++++ src/transmode.c 2004-08-29 15:18:19.032723360 +0930
+@@ -31,6 +31,9 @@
+ int rs = 0;
+ int cs = 0;
+ NET_STREAM sd_server = NULL;
++#ifdef HAVE_PAM
++ int pam_retval;
++#endif
+
+ rs = auth_ident (addr, session.clientname, sizeof (session.clientname));
+
diff --git a/mail-filter/anubis/files/digest-anubis-3.9.95 b/mail-filter/anubis/files/digest-anubis-3.9.95
new file mode 100644
index 000000000000..dd80bdadfbdc
--- /dev/null
+++ b/mail-filter/anubis/files/digest-anubis-3.9.95
@@ -0,0 +1 @@
+MD5 5035697e519b3e219b2fbe58030a53ca anubis-3.9.95.tar.gz 814555