summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gnuplot')
-rw-r--r--media-gfx/gnuplot/ChangeLog8
-rw-r--r--media-gfx/gnuplot/files/digest-gnuplot-3.7.21
-rw-r--r--media-gfx/gnuplot/gnuplot-3.7.2.ebuild77
3 files changed, 85 insertions, 1 deletions
diff --git a/media-gfx/gnuplot/ChangeLog b/media-gfx/gnuplot/ChangeLog
index e47eafca5944..b19dc9c34500 100644
--- a/media-gfx/gnuplot/ChangeLog
+++ b/media-gfx/gnuplot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/gnuplot
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.6 2002/09/19 20:05:26 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/ChangeLog,v 1.7 2002/11/06 09:09:57 agenkin Exp $
+
+*gnuplot-3.7.2 (06 Nov 2002)
+
+ 06 Nov 2002; Arcady Genkin <agenkin@gentoo.org> gnuplot-3.7.2.ebuild :
+
+ Version bump.
*gnuplot-3.7.1-r3 (12 Apr 2002)
diff --git a/media-gfx/gnuplot/files/digest-gnuplot-3.7.2 b/media-gfx/gnuplot/files/digest-gnuplot-3.7.2
new file mode 100644
index 000000000000..4fcda79ff70d
--- /dev/null
+++ b/media-gfx/gnuplot/files/digest-gnuplot-3.7.2
@@ -0,0 +1 @@
+MD5 92f2ef0d6ab39a3fcaa0d008bf1b21c8 gnuplot-3.7.2.tar.gz 1399872
diff --git a/media-gfx/gnuplot/gnuplot-3.7.2.ebuild b/media-gfx/gnuplot/gnuplot-3.7.2.ebuild
new file mode 100644
index 000000000000..40afdd77aad6
--- /dev/null
+++ b/media-gfx/gnuplot/gnuplot-3.7.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnuplot/gnuplot-3.7.2.ebuild,v 1.1 2002/11/06 09:09:57 agenkin Exp $
+
+IUSE="X readline svga plotutils"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Quick and useful plotting program"
+SRC_URI="mirror://sourceforge/gnuplot/${P}.tar.gz"
+HOMEPAGE="http://www.gnuplot.info"
+
+SLOT="0"
+LICENSE="gnuplot"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="media-libs/libpng
+ X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ readline? ( sys-libs/readline )
+ plotutils? ( media-libs/plotutils )"
+
+src_compile() {
+ local myconf
+ #--with-lasergnu flag seems to be broken and I'm too lazy to fix now
+ #myconf=" --with-png --without-gd --with-lasergnu"
+ myconf=" --with-png --without-gd --with-plot=/usr/lib"
+ #--with-plot enables the Gnu plotutils library
+ #need to specify path to differentiate from Unix plot
+
+ use plotutils \
+ && myconf="${myconf} --with-plot=/usr/lib" \
+ || myconf="${myconf} --without-plot"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu" \
+ || myconf="${myconf} --with-readline"
+
+ use svga \
+ && myconf="${myconf} --with-linux-vga" \
+ || myconf="${myconf} --without-linux-vga"
+
+ econf \
+ --datadir=/usr/share/gnuplot \
+ ${myconf} || die
+
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' \
+ -e 's/mandir = \/usr/mandir = ${prefix}/' \
+ Makefile.orig > Makefile
+
+ cd docs
+ mv Makefile Makefile.orig
+ sed -e 's/datadir = \/usr/datadir = ${prefix}/' \
+ Makefile.orig > Makefile
+
+ cd ${S}
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+
+ dodoc 0* ChangeLog CodeStyle Copyright NEWS PGPKEYS TODO
+}
+
+pkg_postinst() {
+ if [ "`use svga`" ] ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually chmod u+s /usr/bin/gnuplot"
+ fi
+}