summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gle/gle-3.1.0-r1.ebuild')
-rw-r--r--media-libs/gle/gle-3.1.0-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-libs/gle/gle-3.1.0-r1.ebuild b/media-libs/gle/gle-3.1.0-r1.ebuild
index 1deb59a05089..c2acc6b024f9 100644
--- a/media-libs/gle/gle-3.1.0-r1.ebuild
+++ b/media-libs/gle/gle-3.1.0-r1.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.1.0-r1.ebuild,v 1.2 2006/09/06 20:42:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.1.0-r1.ebuild,v 1.3 2006/10/29 23:41:16 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.4"
inherit autotools multilib
@@ -20,7 +23,10 @@ DEPEND="virtual/opengl
virtual/glut
app-admin/eselect-opengl"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
# Replace inclusion of malloc.h with stdlib.h as needed by Mac OS X and
# FreeBSD. See bug #130340.
sed -i -e 's:malloc.h:stdlib.h:g' src/*
@@ -28,7 +34,9 @@ src_compile() {
# Don't build binary examples as they never get installed. See bug 141859.
sed -i -e 's:examples::' Makefile.am
eautoreconf
+}
+src_compile() {
econf --with-x \
--x-libraries=/usr/$(get_libdir)/opengl/xorg-x11 \
|| die "econf failed."