summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins/gst-plugins-0.8.1.ebuild')
-rw-r--r--media-libs/gst-plugins/gst-plugins-0.8.1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/gst-plugins/gst-plugins-0.8.1.ebuild b/media-libs/gst-plugins/gst-plugins-0.8.1.ebuild
new file mode 100644
index 000000000000..7e33c40b8df4
--- /dev/null
+++ b/media-libs/gst-plugins/gst-plugins-0.8.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/gst-plugins-0.8.1.ebuild,v 1.1 2004/04/23 16:57:50 foser Exp $
+
+# IMPORTANT
+#
+# Since gst-plugins uses a local copy of ffmpeg we consider this a non-external plugin
+# In essence this means gst-plugins without any external plugins already provides a
+# wide range of audio/video codecs
+#
+# This may change in the future, but for now 3rd-party apps do probably not need to depend
+# on mpeg/avi plugins etcetera unless they are directly referenced
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins gnome2 eutils flag-o-matic
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+LICENSE="GPL-2"
+
+IUSE="esd alsa oss"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+
+RDEPEND="=media-libs/gstreamer-${PV}*
+ >=gnome-base/gconf-1.2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+PDEPEND="oss? ( >=media-plugins/gst-plugins-oss-${PV} )
+ alsa? ( >=media-plugins/gst-plugins-alsa-${PV} )
+ esd? ( >=media-plugins/gst-plugins-esd-${PV} )"
+
+# we need x for the x overlay to get linked
+GST_PLUGINS_BUILD="x xshm"
+
+# overrides the eclass
+src_unpack() {
+
+ unpack ${A}
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS COPYING INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+ gst-plugins_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+ gst-plugins_pkg_postrm
+
+}