summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/ChangeLog9
-rw-r--r--media-libs/jpeg/jpeg-8.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index 20faf0bbc8ab..b18ac8cacf96 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/jpeg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.85 2009/10/26 19:38:12 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.86 2010/01/12 20:31:49 ssuominen Exp $
+
+*jpeg-8 (12 Jan 2010)
+
+ 12 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> +jpeg-8.ebuild:
+ Version bump.
26 Oct 2009; Raúl Porcel <armin76@gentoo.org> jpeg-7.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #285598
diff --git a/media-libs/jpeg/jpeg-8.ebuild b/media-libs/jpeg/jpeg-8.ebuild
new file mode 100644
index 000000000000..39bba434eee8
--- /dev/null
+++ b/media-libs/jpeg/jpeg-8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-8.ebuild,v 1.1 2010/01/12 20:31:49 ssuominen Exp $
+
+EAPI="2"
+
+DEB_PV="7-1"
+DEB_PN="libjpeg7"
+DEB="${DEB_PN}_${DEB_PV}"
+
+inherit eutils libtool multilib
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz
+ mirror://debian/pool/main/libj/${DEB_PN}/${DEB}.diff.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${DEB}.diff
+ cp "${FILESDIR}"/Makefile.in.extra debian/extra/Makefile.in
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch
+ elibtoolize
+ # hook the Debian extra dir into the normal jpeg build env
+ sed -i '/all:/s:$:\n\t./config.status --file debian/extra/Makefile\n\t$(MAKE) -C debian/extra $@:' Makefile.in
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ --enable-static \
+ --enable-maxmem=64
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc change.log example.c README *.txt
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libjpeg.so.7
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libjpeg.so.7
+}