summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/liblingoteach')
-rw-r--r--media-libs/liblingoteach/ChangeLog10
-rw-r--r--media-libs/liblingoteach/liblingoteach-0.2.1.ebuild35
-rw-r--r--media-libs/liblingoteach/liblingoteach-0.2.3.ebuild32
3 files changed, 40 insertions, 37 deletions
diff --git a/media-libs/liblingoteach/ChangeLog b/media-libs/liblingoteach/ChangeLog
index 886c49e093ae..cbba3d916564 100644
--- a/media-libs/liblingoteach/ChangeLog
+++ b/media-libs/liblingoteach/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/liblingoteach
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/liblingoteach/ChangeLog,v 1.3 2007/02/03 18:30:29 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblingoteach/ChangeLog,v 1.4 2008/04/24 11:21:42 drac Exp $
+
+*liblingoteach-0.2.3 (24 Apr 2008)
+
+ 24 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ -liblingoteach-0.2.1.ebuild, +liblingoteach-0.2.3.ebuild:
+ Version bump.
03 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/media-libs/liblingoteach/liblingoteach-0.2.1.ebuild b/media-libs/liblingoteach/liblingoteach-0.2.1.ebuild
deleted file mode 100644
index 0d73b7c5ae16..000000000000
--- a/media-libs/liblingoteach/liblingoteach-0.2.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/liblingoteach/liblingoteach-0.2.1.ebuild,v 1.1 2004/12/30 05:44:54 chriswhite Exp $
-
-inherit eutils
-
-DESCRIPTION="A library to support lingoteach-ui and for generic lesson development."
-HOMEPAGE="http://www.lingoteach.org"
-SRC_URI="mirror://sourceforge/lingoteach/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc"
-IUSE="debug zlib"
-DEPEND="dev-util/pkgconfig
- zlib? ( sys-libs/zlib )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- econf \
- $(use_enable zlib compression) \
- $(use_enable debug) \
- || die "econf failed"
-
- sed -i -e "s:^HTML_DIR = :HTML_DIR = ${D}/:" -i doc/Makefile
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-}
diff --git a/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild b/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild
new file mode 100644
index 000000000000..30d24fc47ea6
--- /dev/null
+++ b/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblingoteach/liblingoteach-0.2.3.ebuild,v 1.1 2008/04/24 11:21:42 drac Exp $
+
+DESCRIPTION="A library to support lingoteach-ui and for generic lesson development."
+HOMEPAGE="http://lingoteach.sourceforge.net"
+SRC_URI="mirror://sourceforge/lingoteach/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE="debug zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ $(use_enable zlib compression) \
+ $(use_enable debug)
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake HTML_DIR="/usr/share/doc/${PF}" DOC_MODULE="" \
+ DESTDIR="${D}" install || die "emake install failed."
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README
+}