summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/audacious-plugins')
-rw-r--r--media-plugins/audacious-plugins/ChangeLog7
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild119
-rw-r--r--media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch45
-rw-r--r--media-plugins/audacious-plugins/files/1.5.1-missing-include.patch10
-rw-r--r--media-plugins/audacious-plugins/metadata.xml2
5 files changed, 6 insertions, 177 deletions
diff --git a/media-plugins/audacious-plugins/ChangeLog b/media-plugins/audacious-plugins/ChangeLog
index aa7dd6ddcf6b..25959b9ad63e 100644
--- a/media-plugins/audacious-plugins/ChangeLog
+++ b/media-plugins/audacious-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/audacious-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.150 2009/11/26 17:44:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/ChangeLog,v 1.151 2009/11/27 12:16:14 chainsaw Exp $
+
+ 27 Nov 2009; <chainsaw@gentoo.org> -files/1.5.1-libmtp-0.3.0-API.patch,
+ -files/1.5.1-missing-include.patch, -audacious-plugins-1.5.1-r3.ebuild,
+ metadata.xml:
+ Remove old ebuild.
26 Nov 2009; Raúl Porcel <armin76@gentoo.org>
audacious-plugins-2.1-r1.ebuild:
diff --git a/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild b/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild
deleted file mode 100644
index 33545d503468..000000000000
--- a/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-plugins/audacious-plugins-1.5.1-r3.ebuild,v 1.11 2009/11/11 13:04:45 ssuominen Exp $
-
-inherit eutils flag-o-matic autotools
-
-MY_P="${P/_/-}"
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
-HOMEPAGE="http://audacious-media-player.org/"
-SRC_URI="http://distfiles.atheme.org/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="aac adplug alsa chardet esd flac gnome jack lirc modplug mp3 mtp nls oss pulseaudio scrobbler sdl sid sndfile sse2 timidity tta vorbis wavpack wma"
-
-RDEPEND="app-arch/unzip
- >=dev-libs/libcdio-0.79-r1
- >=dev-libs/dbus-glib-0.60
- dev-libs/libxml2
- >=media-libs/libcddb-1.2.1
- >=media-sound/audacious-1.5.1-r1
- >=net-misc/neon-0.26.4
- >=x11-libs/gtk+-2.10
- adplug? ( >=dev-cpp/libbinio-1.4 )
- alsa? ( >=media-libs/alsa-lib-1.0.16 )
- esd? ( >=media-sound/esound-0.2.38-r1 )
- flac? ( >=media-libs/libvorbis-1.0
- >=media-libs/flac-1.2.1-r1 )
- jack? ( >=media-libs/bio2jack-0.4
- media-sound/jack-audio-connection-kit )
- lirc? ( app-misc/lirc )
- mp3? ( media-libs/libmad )
- mtp? ( media-libs/libmtp )
- pulseaudio? ( >=media-sound/pulseaudio-0.9.3 )
- scrobbler? ( net-misc/curl )
- sdl? ( >=media-libs/libsdl-1.2.5 )
- sid? ( media-libs/libsidplay )
- sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
- timidity? ( media-sound/timidity++ )
- tta? ( media-libs/libid3tag )
- vorbis? ( >=media-libs/libvorbis-1.2.0
- >=media-libs/libogg-1.1.3 )
- wavpack? ( >=media-sound/wavpack-4.41.0 )
- wma? ( >=media-libs/libmms-0.3 )"
-
-DEPEND="${RDEPEND}
- nls? ( dev-util/intltool )
- >=dev-util/pkgconfig-0.9.0"
-
-mp3_warning() {
- if ! useq mp3 ; then
- ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Bug 232418; patch by Ivan Iraci <ivanhoe@vfemail.net>
- epatch "${FILESDIR}/${PV}-missing-include.patch"
- # Bug 230995; patch by Linus Walleij
- # http://bugzilla.atheme.org/show_bug.cgi?id=35
- # Rebased from hg head to 1.5.1
- epatch "${FILESDIR}/${PV}-libmtp-0.3.0-API.patch"
- AT_M4DIR="m4" eautoreconf
-}
-
-src_compile() {
- mp3_warning
-
- econf \
- --enable-cdaudio \
- --enable-dbus \
- --enable-neon \
- --disable-projectm \
- --disable-projectm-1.0 \
- --disable-rootvis \
- $(use_enable aac) \
- $(use_enable adplug) \
- $(use_enable alsa) \
- --disable-arts \
- $(use_enable chardet) \
- $(use_enable esd) \
- $(use_enable flac flacng) \
- $(use_enable flac filewriter_flac) \
- $(use_enable jack) \
- $(use_enable gnome gnomeshortcuts) \
- $(use_enable lirc) \
- $(use_enable mp3) \
- $(use_enable modplug) \
- --disable-musepack \
- $(use_enable mtp mtp_up) \
- $(use_enable nls) \
- $(use_enable oss) \
- $(use_enable pulseaudio pulse) \
- $(use_enable sdl paranormal) \
- $(use_enable sid) \
- $(use_enable sndfile) \
- $(use_enable sse2) \
- $(use_enable timidity) \
- $(use_enable tta) \
- $(use_enable vorbis) \
- $(use_enable wavpack) \
- $(use_enable wma) \
- || die
-
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS
-}
-
-pkg_postinst() {
- mp3_warning
-}
diff --git a/media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch b/media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch
deleted file mode 100644
index 532026af8adb..000000000000
--- a/media-plugins/audacious-plugins/files/1.5.1-libmtp-0.3.0-API.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -NrU5 audacious-plugins-1.5.1.orig/configure.ac audacious-plugins-1.5.1/configure.ac
---- audacious-plugins-1.5.1.orig/configure.ac 2008-09-03 12:59:59.000000000 +0200
-+++ audacious-plugins-1.5.1/configure.ac 2008-09-03 13:02:47.000000000 +0200
-@@ -1363,10 +1363,15 @@
- if test "x$have_mtp_up" = "xyes"; then
- have_mtp_up=yes
- PKG_CHECK_MODULES(MTP, [libmtp >= 0.1.3], [GENERAL_PLUGINS="$GENERAL_PLUGINS mtp_up" ], [have_mtp_up="no"])
- MTP_LIBS=`pkg-config --libs libmtp`
- MTP_CFLAGS=`pkg-config --cflags libmtp`
-+ dnl Check for libmtp 0.3.0+
-+ PKG_CHECK_EXISTS( [libmtp >= 0.3.0], [libmtp_030_pkg=yes], [libmtp_030_pkg=no])
-+ if test x"$libmtp_030_pkg" = "xyes" ; then
-+ AC_DEFINE([HAVE_LIBMTP_030], 1, [indicates if at least libmtp 0.3.0 is installed])
-+ fi
- else
- have_mtp_up=no
- AC_MSG_RESULT([*** mtp upload plugin disabled by request ***])
- fi
- AC_SUBST(MTP_LIBS)
-diff -NrU5 audacious-plugins-1.5.1.orig/src/mtp_up/mtp.c audacious-plugins-1.5.1/src/mtp_up/mtp.c
---- audacious-plugins-1.5.1.orig/src/mtp_up/mtp.c 2008-09-03 12:59:59.000000000 +0200
-+++ audacious-plugins-1.5.1/src/mtp_up/mtp.c 2008-09-03 13:05:55.000000000 +0200
-@@ -190,16 +190,21 @@
- tmp = g_strescape(from_path,NULL);
- filename=g_filename_from_uri(tmp,NULL,NULL);
-
- g_free(from_path);
- g_free(tmp);
-- parent_id = mtp_device->default_music_folder;
-
- #if DEBUG
- g_print("Uploading track '%s'\n",filename);
- #endif
-+#ifdef HAVE_LIBMTP_030
-+ gentrack->parent_id = mtp_device->default_music_folder;
-+ ret = LIBMTP_Send_Track_From_File(mtp_device, filename , gentrack, NULL , NULL);
-+#else
-+ parent_id = mtp_device->default_music_folder;
- ret = LIBMTP_Send_Track_From_File(mtp_device, filename , gentrack, NULL , NULL, parent_id);
-+#endif
- LIBMTP_destroy_track_t(gentrack);
- if (ret == 0)
- g_print("Track upload finished!\n");
- else
- {
diff --git a/media-plugins/audacious-plugins/files/1.5.1-missing-include.patch b/media-plugins/audacious-plugins/files/1.5.1-missing-include.patch
deleted file mode 100644
index 0a3f20f14422..000000000000
--- a/media-plugins/audacious-plugins/files/1.5.1-missing-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- audacious-plugins-1.5.1/src/amidi-plug/i_configure.c~ 2008-05-23 16:44:19.000000000 -0600
-+++ audacious-plugins-1.5.1/src/amidi-plug/i_configure.c 2008-06-17 16:29:22.000000000 -0600
-@@ -29,6 +29,7 @@
- #include "i_configure-dummy.h"
- #include "i_utils.h"
- #include <audacious/auddrct.h>
-+#include <audacious/plugin.h>
-
-
- amidiplug_cfg_backend_t * amidiplug_cfg_backend;
diff --git a/media-plugins/audacious-plugins/metadata.xml b/media-plugins/audacious-plugins/metadata.xml
index 9aa36e56362a..dd0d2fa4e954 100644
--- a/media-plugins/audacious-plugins/metadata.xml
+++ b/media-plugins/audacious-plugins/metadata.xml
@@ -11,8 +11,6 @@
support</flag>
<flag name='bs2b'>Enable Bauer Bauer stereophonic-to-binaural
headphone filter</flag>
- <flag name='chardet'>Try to handle non-UTF8 chinese/japanese/korean ID3
- tags</flag>
<flag name='cue'>Support CUE sheets using the libcue library</flag>
<flag name='fluidsynth'>Support FluidSynth as MIDI synth backend</flag>
<flag name='icecast'>Support for Icecast2 streaming</flag>