summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gqradio/gqradio-1.9.1.ebuild')
-rw-r--r--media-sound/gqradio/gqradio-1.9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/gqradio/gqradio-1.9.1.ebuild b/media-sound/gqradio/gqradio-1.9.1.ebuild
new file mode 100644
index 000000000000..f90cc5fd9e45
--- /dev/null
+++ b/media-sound/gqradio/gqradio-1.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gqradio/gqradio-1.9.1.ebuild,v 1.1 2004/04/10 23:27:13 weeve Exp $
+
+IUSE="nls gnome"
+
+DESCRIPTION="GQradio is an FM radio tuner app from the people who brought you GQrmpeg."
+HOMEPAGE="http://gqmpeg.sourceforge.net/radio.html"
+SRC_URI="mirror://sourceforge/gqmpeg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="=x11-libs/gtk+-2*
+ >=media-libs/gdk-pixbuf-0.7.0
+ >=media-libs/gdk-pixbuf-0.13.0"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README SKIN-SPECS TODO
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/gqmpeg.desktop
+ )
+
+}