summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/qmpdclient/qmpdclient-1.0.7.ebuild')
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/qmpdclient/qmpdclient-1.0.7.ebuild b/media-sound/qmpdclient/qmpdclient-1.0.7.ebuild
new file mode 100644
index 000000000000..b53767fd38a1
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-1.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.0.7.ebuild,v 1.1 2006/12/21 19:26:25 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="An easy to use MPD client written in Qt 4.1"
+HOMEPAGE="http://havtknut.tihlde.org/qmpdclient"
+SRC_URI="http://havtknut.tihlde.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-4.2"
+
+src_compile() {
+ ./configure || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodoc README AUTHORS THANKSTO Changelog
+ insinto /usr/share/pixmaps
+ doins icons/qmpdclient{16,22,32,64,128}.png
+ dobin qmpdclient
+
+ make_desktop_entry qmpdclient "QMPDClient" qmpdclient64.png "KDE;Qt;AudioVideo"
+}