summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/drip/drip-0.8.1-r4.ebuild')
-rw-r--r--media-video/drip/drip-0.8.1-r4.ebuild116
1 files changed, 116 insertions, 0 deletions
diff --git a/media-video/drip/drip-0.8.1-r4.ebuild b/media-video/drip/drip-0.8.1-r4.ebuild
new file mode 100644
index 000000000000..8f557ed8a1e8
--- /dev/null
+++ b/media-video/drip/drip-0.8.1-r4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@cvs.gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/drip-0.8.1-r4.ebuild,v 1.1 2002/05/27 19:44:17 azarah Exp $
+
+AF_MINOR_VER="$(avifile-config --data-dir | cut -d. -f2)"
+S=${WORKDIR}/${P}
+DESCRIPTION="Drip - A DVD to DIVX convertor frontend"
+SRC_URI="${SRC_URI} http://drip.sourceforge.net/files/${P}.tar.gz"
+HOMEPAGE="http://drip.sourceforge.net/"
+
+RDEPEND="gnome-base/gnome-libs
+ >=media-video/avifile-0.7.4.20020426-r2
+ >=media-libs/a52dec-0.7.3
+ >=media-libs/divx4linux-20020418
+ >=media-libs/libdvdcss-1.1.1
+ >=media-libs/libdvdread-0.9.2
+ media-libs/gdk-pixbuf"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ >=sys-devel/automake-1.5-r1"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+
+ # Fix the problem that if the /dev/dvd symlink is not absolute,
+ # drip fails to start.
+ patch -p1 < ${FILESDIR}/${P}-fix-dvd-symlink.patch || die
+
+ # Fix hardcoded path of plugins
+ cd ${S}
+ cp encoder/plugin-loader.cpp encoder/plugin-loader.cpp.orig
+ sed -e "s:/usr/local/lib:/usr/lib:g" \
+ encoder/plugin-loader.cpp.orig >encoder/plugin-loader.cpp
+
+ # Fix missing #include <stdio.h>
+ patch -p1 < ${FILESDIR}/${P}-missing-stdio.patch || die
+
+ # Fixup to work with avifile-0.${AF_MINOR_VER}
+ cd ${S}/encoder
+ for x in encoder.hh main.hh encoder.cpp external.cpp
+ do
+ cp ${x} ${x}.orig
+ sed -e "s:AVIFILE_MINOR_VERSION==6:AVIFILE_MINOR_VERSION==${AF_MINOR_VER}:g" \
+ ${x}.orig >${x}
+ done
+
+ # Fix it to work with the suffix the new avifile introduces.
+# cd ${S}
+# for x in $(find . -name 'Makefile.am') configure.in
+# do
+# cp ${x} ${x}.orig
+# sed -e "s:avifile-config:avifile-config0.${AF_MINOR_VER}:g" \
+# ${x}.orig >${x}
+# done
+
+ cd ${S}
+ # Remove stale script ... "automake --add-missing" will add it again
+ rm -f ${S}/missing
+ export WANT_AUTOMAKE_1_5=1
+ aclocal -I macros
+ automake --add-missing
+ autoconf
+}
+
+src_compile() {
+
+ export WANT_AUTOMAKE_1_5=1
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ CFLAGS= \
+ CXXFLAGS= \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ sysconfdir=${D}/etc \
+ drip_helpdir=${D}/usr/share/gnome/help/drip/C \
+ drip_pixmapdir=${D}/usr/share/pixmaps \
+ install || die
+
+ # Remove liba52.so.* as ac52dec provides this
+ rm ${D}/usr/lib/liba52*
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+
+ # Custom script for drip to get the *real* dvd device
+ # It is a bit rough around the edges, but hopefully will do the trick.
+ dobin ${FILESDIR}/dripgetdvd.sh
+
+ insinto /usr/share/pixmaps
+ newins ${S}/pixmaps/drip_logo.jpg drip.jpg
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/drip.desktop
+}
+