summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/makemkv')
-rw-r--r--media-video/makemkv/ChangeLog11
-rw-r--r--media-video/makemkv/files/makemkv-1.8.6-makefile.linux.patch20
-rw-r--r--media-video/makemkv/makemkv-1.8.3.ebuild102
-rw-r--r--media-video/makemkv/makemkv-1.8.4.ebuild102
-rw-r--r--media-video/makemkv/makemkv-1.8.5-r1.ebuild (renamed from media-video/makemkv/makemkv-1.8.1-r1.ebuild)2
-rw-r--r--media-video/makemkv/makemkv-1.8.6.ebuild (renamed from media-video/makemkv/makemkv-1.8.5.ebuild)2
6 files changed, 32 insertions, 207 deletions
diff --git a/media-video/makemkv/ChangeLog b/media-video/makemkv/ChangeLog
index dbd29c11ed3f..564dd04b0055 100644
--- a/media-video/makemkv/ChangeLog
+++ b/media-video/makemkv/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/makemkv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/ChangeLog,v 1.25 2013/09/14 02:13:23 mattm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/ChangeLog,v 1.26 2013/11/16 23:19:41 mattm Exp $
+
+*makemkv-1.8.5-r1 (16 Nov 2013)
+*makemkv-1.8.6 (16 Nov 2013)
+
+ 16 Nov 2013; Matthew Marlowe <mattm@gentoo.org>
+ +files/makemkv-1.8.6-makefile.linux.patch, +makemkv-1.8.5-r1.ebuild,
+ +makemkv-1.8.6.ebuild, -makemkv-1.8.1-r1.ebuild, -makemkv-1.8.3.ebuild,
+ -makemkv-1.8.4.ebuild, -makemkv-1.8.5.ebuild:
+ Version bump, Fix download path for 1.8.5, Prune legacy ebuilds.
14 Sep 2013; Matthew Marlowe <mattm@gentoo.org>
+files/makemkv-1.8.5-makefile.linux.patch:
diff --git a/media-video/makemkv/files/makemkv-1.8.6-makefile.linux.patch b/media-video/makemkv/files/makemkv-1.8.6-makefile.linux.patch
new file mode 100644
index 000000000000..bb3360b29b87
--- /dev/null
+++ b/media-video/makemkv/files/makemkv-1.8.6-makefile.linux.patch
@@ -0,0 +1,20 @@
+--- makemkv-oss-1.8.6/makefile.linux.orig
++++ makemkv-oss-1.8.6/makefile.linux
+@@ -8,7 +8,7 @@
+ MOC=moc
+ endif
+
+-CXXOPTS=-Os -D_GNU_SOURCE -D_linux_
++CXXOPTS=-D_GNU_SOURCE -D_linux_
+
+ BUILDINFO_ARCH_NAME=$(shell $(GCC) -dumpmachine)
+ BUILDINFO_BUILD_DATE=$(shell date)
+@@ -38,7 +38,7 @@
+ install -D -m 644 makemkvgui/src/img/128/mkv_icon.png $(DESTDIR)$(PREFIX)/share/icons/hicolor/128x128/apps/makemkv.png
+
+ out/%: out/%.full
+- objcopy --strip-all --strip-debug --strip-unneeded --discard-all $< $@
++ objcopy --discard-all $< $@
+
+ out/libdriveio.so.0.full:
+ mkdir -p out
diff --git a/media-video/makemkv/makemkv-1.8.3.ebuild b/media-video/makemkv/makemkv-1.8.3.ebuild
deleted file mode 100644
index aa1a66c87549..000000000000
--- a/media-video/makemkv/makemkv-1.8.3.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.3.ebuild,v 1.2 2013/09/05 04:03:40 mattm Exp $
-
-EAPI=4
-inherit eutils gnome2-utils multilib flag-o-matic
-
-MY_P=makemkv-oss-${PV}
-MY_PB=makemkv-bin-${PV}
-
-DESCRIPTION="Tool for ripping Blu-Ray, HD-DVD and DVD discs and copying content to a Matroska container"
-HOMEPAGE="http://www.makemkv.com/"
-SRC_URI="http://www.makemkv.com/download/old/${MY_P}.tar.gz
- http://www.makemkv.com/download/old/${MY_PB}.tar.gz"
-
-LICENSE="LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="multilib"
-
-QA_PREBUILT="opt/bin/makemkvcon opt/bin/mmdtsdec"
-RESTRICT="mirror"
-
-RDEPEND="dev-libs/expat
- dev-libs/openssl:0
- sys-libs/zlib
- virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtdbus:4
- dev-qt/qtgui:4
- amd64? ( multilib? ( app-emulation/emul-linux-x86-baselibs ) )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.linux.patch
-}
-
-src_configure() {
- replace-flags -O* -Os
-}
-
-src_compile() {
- emake GCC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" -f makefile.linux
-}
-
-src_install() {
- # install oss package
- dolib.so out/libdriveio.so.0
- dolib.so out/libmakemkv.so.1
- dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
- dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
- dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
- dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
- into /opt
- dobin out/makemkv
-
- local res
- for res in 16 22 32 64 128; do
- newicon -s ${res} makemkvgui/share/icons/${res}x${res}/makemkv.png ${PN}.png
- done
-
- make_desktop_entry ${PN} MakeMKV ${PN} 'Qt;AudioVideo;Video'
-
- # install bin package
- pushd "${WORKDIR}"/${MY_PB}/bin >/dev/null
- if use x86; then
- dobin i386/{makemkvcon,mmdtsdec}
- elif use amd64; then
- dobin amd64/makemkvcon
- use multilib && dobin i386/mmdtsdec
- fi
- popd >/dev/null
-
- # install license and default profile
- pushd "${WORKDIR}"/${MY_PB}/src/share >/dev/null
- insinto /usr/share/MakeMKV
- doins *.{gz,xml}
- popd >/dev/null
-}
-
-pkg_preinst() { gnome2_icon_savelist; }
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- elog "While MakeMKV is in beta mode, upstream has provided a license"
- elog "to use if you do not want to purchase one."
- elog ""
- elog "See this forum thread for more information, including the key:"
- elog "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053"
- elog ""
- elog "Note that beta license may have an expiration date and you will"
- elog "need to check for newer licenses/releases. "
- elog ""
- elog "If this is a new install, remember to copy the default profile"
- elog "to the config directory:"
- elog "cp /usr/share/MakeMKV/default.mmcp.xml ~/.MakeMKV/"
-}
-
-pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/media-video/makemkv/makemkv-1.8.4.ebuild b/media-video/makemkv/makemkv-1.8.4.ebuild
deleted file mode 100644
index 3a11fe38d010..000000000000
--- a/media-video/makemkv/makemkv-1.8.4.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.4.ebuild,v 1.2 2013/09/13 23:41:07 mattm Exp $
-
-EAPI=4
-inherit eutils gnome2-utils multilib flag-o-matic
-
-MY_P=makemkv-oss-${PV}
-MY_PB=makemkv-bin-${PV}
-
-DESCRIPTION="Tool for ripping Blu-Ray, HD-DVD and DVD discs and copying content to a Matroska container"
-HOMEPAGE="http://www.makemkv.com/"
-SRC_URI="http://www.makemkv.com/download/old/${MY_P}.tar.gz
- http://www.makemkv.com/download/old/${MY_PB}.tar.gz"
-
-LICENSE="LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="multilib"
-
-QA_PREBUILT="opt/bin/makemkvcon opt/bin/mmdtsdec"
-RESTRICT="mirror"
-
-RDEPEND="dev-libs/expat
- dev-libs/openssl:0
- sys-libs/zlib
- virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtdbus:4
- dev-qt/qtgui:4
- amd64? ( multilib? ( app-emulation/emul-linux-x86-baselibs ) )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.linux.patch
-}
-
-src_configure() {
- replace-flags -O* -Os
-}
-
-src_compile() {
- emake GCC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" -f makefile.linux
-}
-
-src_install() {
- # install oss package
- dolib.so out/libdriveio.so.0
- dolib.so out/libmakemkv.so.1
- dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
- dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
- dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
- dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
- into /opt
- dobin out/makemkv
-
- local res
- for res in 16 22 32 64 128; do
- newicon -s ${res} makemkvgui/share/icons/${res}x${res}/makemkv.png ${PN}.png
- done
-
- make_desktop_entry ${PN} MakeMKV ${PN} 'Qt;AudioVideo;Video'
-
- # install bin package
- pushd "${WORKDIR}"/${MY_PB}/bin >/dev/null
- if use x86; then
- dobin i386/{makemkvcon,mmdtsdec}
- elif use amd64; then
- dobin amd64/makemkvcon
- use multilib && dobin i386/mmdtsdec
- fi
- popd >/dev/null
-
- # install license and default profile
- pushd "${WORKDIR}"/${MY_PB}/src/share >/dev/null
- insinto /usr/share/MakeMKV
- doins *.{gz,xml}
- popd >/dev/null
-}
-
-pkg_preinst() { gnome2_icon_savelist; }
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- elog "While MakeMKV is in beta mode, upstream has provided a license"
- elog "to use if you do not want to purchase one."
- elog ""
- elog "See this forum thread for more information, including the key:"
- elog "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053"
- elog ""
- elog "Note that beta license may have an expiration date and you will"
- elog "need to check for newer licenses/releases. "
- elog ""
- elog "If this is a new install, remember to copy the default profile"
- elog "to the config directory:"
- elog "cp /usr/share/MakeMKV/default.mmcp.xml ~/.MakeMKV/"
-}
-
-pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/media-video/makemkv/makemkv-1.8.1-r1.ebuild b/media-video/makemkv/makemkv-1.8.5-r1.ebuild
index ef0d38122b5d..320f8e83e867 100644
--- a/media-video/makemkv/makemkv-1.8.1-r1.ebuild
+++ b/media-video/makemkv/makemkv-1.8.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.1-r1.ebuild,v 1.1 2013/06/22 02:17:04 mattm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.5-r1.ebuild,v 1.1 2013/11/16 23:19:41 mattm Exp $
EAPI=4
inherit eutils gnome2-utils multilib flag-o-matic
diff --git a/media-video/makemkv/makemkv-1.8.5.ebuild b/media-video/makemkv/makemkv-1.8.6.ebuild
index c58a595166a5..95239f04125f 100644
--- a/media-video/makemkv/makemkv-1.8.5.ebuild
+++ b/media-video/makemkv/makemkv-1.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.5.ebuild,v 1.1 2013/09/13 23:41:07 mattm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.8.6.ebuild,v 1.1 2013/11/16 23:19:41 mattm Exp $
EAPI=4
inherit eutils gnome2-utils multilib flag-o-matic