summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc/vlc-0.9.0_alpha20080110.ebuild')
-rw-r--r--media-video/vlc/vlc-0.9.0_alpha20080110.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/media-video/vlc/vlc-0.9.0_alpha20080110.ebuild b/media-video/vlc/vlc-0.9.0_alpha20080110.ebuild
index 731a1ea8f0e5..6ae95b8aae14 100644
--- a/media-video/vlc/vlc-0.9.0_alpha20080110.ebuild
+++ b/media-video/vlc/vlc-0.9.0_alpha20080110.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.9.0_alpha20080110.ebuild,v 1.1 2008/01/10 22:21:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.9.0_alpha20080110.ebuild,v 1.2 2008/01/11 09:40:06 aballier Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
-inherit eutils wxwidgets multilib autotools toolchain-funcs gnome2 nsplugins qt4
+inherit eutils wxwidgets multilib autotools toolchain-funcs gnome2 nsplugins qt4 flag-o-matic
MY_PV="${PV/_/-}"
MY_PV="${MY_PV/-beta/-test}"
@@ -185,6 +185,10 @@ src_unpack() {
}
src_compile () {
+
+ # It would fail if -fforce-addr is used due to too few registers...
+ use x86 && filter-flags -fforce-addr
+
local XPIDL=""
local MOZILLA_CONFIG=""