summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avifile/ChangeLog9
-rw-r--r--media-video/avifile/avifile-0.6.0.20011220-r2.ebuild4
-rw-r--r--media-video/avifile/avifile-0.6.0.20011220-r3.ebuild88
-rw-r--r--media-video/avifile/files/digest-avifile-0.6.0.20011220-r31
4 files changed, 99 insertions, 3 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index efe6ffe64e32..52e3419bd3bc 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.6 2002/04/14 01:47:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.7 2002/04/14 02:11:31 seemant Exp $
+
+avifile-0.6.0.20011220-r3 (13 Apr 2002)
+
+ 13 Apr 2002; Seemant Kulleen <seemant@gentoo.org>
+
+ A more dynamic way to cohese with kde2/kde3. If this works through testing
+ I will make this the r2 ebuild instead.
avifile-0.6.0.20011220-r2 (13 Apr 2002)
diff --git a/media-video/avifile/avifile-0.6.0.20011220-r2.ebuild b/media-video/avifile/avifile-0.6.0.20011220-r2.ebuild
index 468d81e77b0f..7d88422daa72 100644
--- a/media-video/avifile/avifile-0.6.0.20011220-r2.ebuild
+++ b/media-video/avifile/avifile-0.6.0.20011220-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.6.0.20011220-r2.ebuild,v 1.1 2002/04/14 01:47:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.6.0.20011220-r2.ebuild,v 1.2 2002/04/14 02:11:31 seemant Exp $
MY_P=${P/.200/-200}
MY_S=${MY_P/avifile-/avifile}
@@ -14,9 +14,9 @@ HOMEPAGE="http://divx.euro.ru/"
DEPEND=">=media-libs/divx4linux-20011025
media-libs/jpeg
media-libs/win32codecs
- sdl? ( >=media-libs/libsdl-1.2.2 )
qt? ( =x11-libs/qt-2* )
nas? ( >=media-libs/nas-1.4.2 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
oggvorbis? ( media-libs/libvorbis )"
diff --git a/media-video/avifile/avifile-0.6.0.20011220-r3.ebuild b/media-video/avifile/avifile-0.6.0.20011220-r3.ebuild
new file mode 100644
index 000000000000..ee0fd9531019
--- /dev/null
+++ b/media-video/avifile/avifile-0.6.0.20011220-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.6.0.20011220-r3.ebuild,v 1.1 2002/04/14 02:11:31 seemant Exp $
+
+MY_P=${P/.200/-200}
+MY_S=${MY_P/avifile-/avifile}
+MY_S=${MY_S/.0-200/-200}
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}admin.tgz"
+HOMEPAGE="http://divx.euro.ru/"
+
+DEPEND=">=media-libs/divx4linux-20011025
+ media-libs/jpeg
+ media-libs/win32codecs
+ qt? ( =x11-libs/qt-2.3.2* )
+ nas? ( >=media-libs/nas-1.4.2 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+
+src_compile() {
+
+ local myconf
+ local kdepre
+
+ use mmx && myconf="--enable-x86opt"
+ use sse && myconf="--enable-x86opt"
+ use 3dnow && myconf="--enable-x86opt"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=/usr/qt/2" \
+ || myconf="${myconf} --disable-qt"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ || myconf="${myconf} --disable-kde"
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ use nas && LDFLAGS="-L/usr/X11R6/lib -lXt"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ use kde \
+
+ use kde \
+ && ( \
+ kdepre=`kde-config --prefix`
+ myconf="${myconf} --enable-kde" \
+ && LDFLAGS="${LDFLAGS} -L${kdepre}/lib" \
+ && myconf="${myconf} --with-extra-libraries=${kdepre}" \
+ ) || (
+ myconf="${myconf} --disable-kde" \
+ && LDFLAGS="${LDFLAGS}"
+ )
+
+
+ export CFLAGS=${CFLAGS/-O?/-O2}
+ export LDFLAGS
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-quiet \
+ --disable-tsc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ make prefix=${D}/usr install || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
diff --git a/media-video/avifile/files/digest-avifile-0.6.0.20011220-r3 b/media-video/avifile/files/digest-avifile-0.6.0.20011220-r3
new file mode 100644
index 000000000000..a2398611d718
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.6.0.20011220-r3
@@ -0,0 +1 @@
+MD5 89c096520c14a68922669dbda0132baa avifile-0.6.0-20011220admin.tgz 2043485