summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/iftop/files/iftop-1.0_pre3-tinfo.patch')
-rw-r--r--net-analyzer/iftop/files/iftop-1.0_pre3-tinfo.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/iftop/files/iftop-1.0_pre3-tinfo.patch b/net-analyzer/iftop/files/iftop-1.0_pre3-tinfo.patch
new file mode 100644
index 000000000000..a00d48a03263
--- /dev/null
+++ b/net-analyzer/iftop/files/iftop-1.0_pre3-tinfo.patch
@@ -0,0 +1,44 @@
+--- a/configure.in
++++ b/configure.in
+@@ -350,19 +350,23 @@
+ dnl AC_SEARCH_LIBS....
+ dnl
+
+-AC_MSG_CHECKING([for a curses library containing mvchgat])
+-oldLIBS=$LIBS
+-for curseslib in ncursesw curses ncurses ; do
+- LIBS="$oldLIBS -l$curseslib"
+- AC_TRY_LINK([
++PKG_CHECK_MODULES([NCURSES], [ncursesw], [foundcurseslib="$NCURSES_LIBS"], [
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [foundcurseslib="$NCURSES_LIBS"], [
++ AC_MSG_CHECKING([for a curses library containing mvchgat])
++ oldLIBS=$LIBS
++ for curseslib in ncursesw curses ncurses ; do
++ LIBS="$oldLIBS -l$curseslib"
++ AC_TRY_LINK([
+ #include <$curseslib.h>
+ ], [
+ mvchgat(0, 0, 1, A_REVERSE, 0, NULL)
+ ], [
+- foundcurseslib=$curseslib
++ foundcurseslib=-l$curseslib
+ break
+ ])
+-done
++ done
++ ])
++])
+
+ if test x$foundcurseslib = x ; then
+ AC_MSG_RESULT([none found])
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -25,7 +25,7 @@
+ # addrs_ioctl.c addrs_dlpi.c dlcommon.c \
+ # stringmap.c cfgfile.c
+
+-
++iftop_LDADD = $(NCURSES_LIBS)
+
+ noinst_HEADERS = addr_hash.h ether.h ethertype.h extract.h hash.h iftop.h \
+ integers.h ip.h llc.h ns_hash.h options.h resolver.h \