summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-3.95.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-3.95.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/net-analyzer/nmap/nmap-3.95.ebuild b/net-analyzer/nmap/nmap-3.95.ebuild
deleted file mode 100644
index 36f0a512452b..000000000000
--- a/net-analyzer/nmap/nmap-3.95.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.95.ebuild,v 1.2 2006/02/04 10:54:53 spock Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A utility for network exploration or security auditing"
-HOMEPAGE="http://www.insecure.org/nmap/"
-SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="gtk ssl"
-
-DEPEND="virtual/libc
- dev-libs/libpcre
- gtk? ( =x11-libs/gtk+-2* )
- ssl? ( dev-libs/openssl )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed 's:Icon=icon-network:Icon=nmap-logo-64.png:' -i nmapfe.desktop
- echo ";" >> nmapfe.desktop
- epatch ${FILESDIR}/nmap-shtool-nls.patch
-}
-
-src_compile() {
- use ppc-macos && filter-flags -fstrict-aliasing -O2
- econf \
- $(use_with gtk nmapfe) \
- $(use_with ssl openssl) || die
- emake -j1 || die
-}
-
-src_install() {
- einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
- dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
- dohtml docs/*.html
-
- if use gtk; then
- dodir /usr/share/pixmaps
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/nmap-logo-64.png
- fi
-}