summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-4.20.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-4.20.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/net-analyzer/nmap/nmap-4.20.ebuild b/net-analyzer/nmap/nmap-4.20.ebuild
deleted file mode 100644
index 25e475221ffa..000000000000
--- a/net-analyzer/nmap/nmap-4.20.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.20.ebuild,v 1.18 2008/03/04 17:41:02 pva Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A utility for network exploration or security auditing"
-HOMEPAGE="http://www.insecure.org/nmap/"
-SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="gtk ssl"
-
-DEPEND="dev-libs/libpcre
- net-libs/libpcap
- gtk? ( =x11-libs/gtk+-2* )
- ssl? ( dev-libs/openssl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed 's:Icon=icon-network:Icon=nmap-logo-64.png:' -i nmapfe.desktop
- echo ";" >> nmapfe.desktop
- epatch "${FILESDIR}/nmap-shtool-nls.patch"
- epatch "${FILESDIR}/nmap-4.01-nostrip.patch"
- epatch "${FILESDIR}/${P}-osscan.patch"
-}
-
-src_compile() {
- econf \
- --with-libdnet=included \
- $(use_with gtk nmapfe) \
- $(use_with ssl openssl) || die
- emake -j1 || die
-}
-
-src_install() {
- einstall -j1 nmapdatadir="${D}/usr/share/nmap" install || die
- dodoc CHANGELOG HACKING docs/README docs/*.txt || die
-
- use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
-}