summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/rrdtool/rrdtool-1.0.45.ebuild')
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.45.ebuild105
1 files changed, 0 insertions, 105 deletions
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.45.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.45.ebuild
deleted file mode 100644
index 0982dec50bdf..000000000000
--- a/net-analyzer/rrdtool/rrdtool-1.0.45.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.45.ebuild,v 1.11 2004/07/14 22:33:24 agriffis Exp $
-
-inherit perl-module flag-o-matic gnuconfig
-
-DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/"
-SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/${PN}/pub/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc ~alpha ~amd64"
-IUSE="tcltk perl"
-
-DEPEND="perl? ( dev-lang/perl )
- sys-apps/gawk
- >=media-libs/gd-1.8.3"
-RDEPEND="tcltk? ( dev-lang/tcl )"
-
-TCLVER=""
-
-pkg_setup() {
- if use tcltk; then
- TCLVER=`awk -F\' '/TCL_VERSION/ {print $2}' /usr/lib/tclConfig.sh`
- fi
-
- if use perl; then
- perl-module_pkg_setup
- fi
-}
-
-src_compile() {
- filter-mfpmath "sse"
- filter-flags "-ffast-math"
-
- local myconf
- use tcltk \
- && myconf="${myconf} --with-tcllib=/usr/lib" \
- || myconf="${myconf} --without-tcllib"
-
- gnuconfig_update
-
- econf \
- --datadir=/usr/share \
- --enable-shared \
- --with-perl-options='INSTALLMAN1DIR=/usr/share/man/man1 INSTALLMAN3DIR=/usr/share/man/man3 PREFIX=${D}/usr' \
- ${myconf} || die
-
- make || die
-}
-
-src_install() {
- einstall || die
-
- # this package completely ignores mandir settings
-
- doman doc/*.1
- dohtml doc/*.html
- dodoc doc/*.pod
- dodoc doc/*.txt
-
- rm -rf ${D}/usr/doc
- rm -rf ${D}/usr/html
- rm -rf ${D}/usr/man
- rm -rf ${D}/usr/contrib
- rm -rf ${D}/usr/examples
-
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- insinto /usr/share/doc/${PF}/contrib
- doins contrib/*
-
- if use perl ; then
- perlinfo
- mytargets="site-perl-install"
- perl-module_src_install || die
- fi
-
- if use tcltk ; then
- mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
- insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
- doins ${S}/tcl/tclrrd${PV}.so
- echo "package ifneeded Rrd ${PV} [list load [file join \$$dir .. tclrrd${PV}.so]]" \
- >> ${D}/usr/lib/tcl${TCL_VER}/tclrrd${PV}/pkgIndex.tcl
- fi
-
- dodoc COPY* CONTR* README TODO
-}
-
-pkg_preinst() {
- use perl && perl-module_pkg_preinst
-}
-
-pkg_postinst() {
- use perl && perl-module_pkg_postinst
-}
-
-pkg_prerm() {
- use perl && perl-module_pkg_prerm
-}
-
-pkg_postrm() {
- use perl && perl-module_pkg_postrm
-}