summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/metasploit/ChangeLog8
-rw-r--r--net-analyzer/metasploit/files/digest-metasploit-3.0-r1 (renamed from net-analyzer/metasploit/files/digest-metasploit-3.0)0
-rw-r--r--net-analyzer/metasploit/metasploit-3.0-r1.ebuild (renamed from net-analyzer/metasploit/metasploit-3.0.ebuild)8
3 files changed, 13 insertions, 3 deletions
diff --git a/net-analyzer/metasploit/ChangeLog b/net-analyzer/metasploit/ChangeLog
index 68f5eeacc33b..ead5e2c1feb4 100644
--- a/net-analyzer/metasploit/ChangeLog
+++ b/net-analyzer/metasploit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/metasploit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.23 2007/09/09 11:56:20 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.24 2007/10/13 18:14:55 cedk Exp $
+
+*metasploit-3.0-r1 (13 Oct 2007)
+
+ 13 Oct 2007; Cédric Krier <cedk@gentoo.org> -metasploit-3.0.ebuild,
+ +metasploit-3.0-r1.ebuild:
+ Fix rails version for bug #195652
*metasploit-3.0 (09 Sep 2007)
diff --git a/net-analyzer/metasploit/files/digest-metasploit-3.0 b/net-analyzer/metasploit/files/digest-metasploit-3.0-r1
index 2a55a2bd25a4..2a55a2bd25a4 100644
--- a/net-analyzer/metasploit/files/digest-metasploit-3.0
+++ b/net-analyzer/metasploit/files/digest-metasploit-3.0-r1
diff --git a/net-analyzer/metasploit/metasploit-3.0.ebuild b/net-analyzer/metasploit/metasploit-3.0-r1.ebuild
index 2b9a8fc627a6..e1869a45aa5d 100644
--- a/net-analyzer/metasploit/metasploit-3.0.ebuild
+++ b/net-analyzer/metasploit/metasploit-3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-3.0.ebuild,v 1.1 2007/09/09 11:56:20 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-3.0-r1.ebuild,v 1.1 2007/10/13 18:14:55 cedk Exp $
inherit eutils
@@ -19,7 +19,7 @@ IUSE="gtk sqlite sqlite3 postgres httpd"
RDEPEND="dev-lang/ruby
gtk? ( dev-ruby/ruby-libglade2 )
- httpd? ( =dev-ruby/rails-1.2.2* )
+ httpd? ( =dev-ruby/rails-1.2* )
sqlite? ( dev-ruby/sqlite-ruby
dev-ruby/activerecord )
sqlite3? ( dev-ruby/sqlite3-ruby
@@ -37,6 +37,10 @@ pkg_nofetch() {
src_compile() {
epatch "${FILESDIR}"/${P}.patch
+
+ sed -i \
+ -e "s/RAILS_GEM_VERSION = '1.2.2'/RAILS_GEM_VERSION = '1.2'/" \
+ data/msfweb/config/environment.rb || die "sed failed"
}
src_install() {