summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/hcfpcimodem')
-rw-r--r--net-dialup/hcfpcimodem/ChangeLog7
-rw-r--r--net-dialup/hcfpcimodem/hcfpcimodem-1.17.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/net-dialup/hcfpcimodem/ChangeLog b/net-dialup/hcfpcimodem/ChangeLog
index a286175a2a42..5b209a2fc015 100644
--- a/net-dialup/hcfpcimodem/ChangeLog
+++ b/net-dialup/hcfpcimodem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dialup/hcfpcimodem
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.37 2008/07/30 20:56:02 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/ChangeLog,v 1.38 2008/09/25 20:55:12 mrness Exp $
+
+*hcfpcimodem-1.17 (25 Sep 2008)
+
+ 25 Sep 2008; Alin Năstac <mrness@gentoo.org> +hcfpcimodem-1.17.ebuild:
+ Version bump.
*hcfpcimodem-1.16 (30 Jul 2008)
diff --git a/net-dialup/hcfpcimodem/hcfpcimodem-1.17.ebuild b/net-dialup/hcfpcimodem/hcfpcimodem-1.17.ebuild
new file mode 100644
index 000000000000..2b2c7447b974
--- /dev/null
+++ b/net-dialup/hcfpcimodem/hcfpcimodem-1.17.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/hcfpcimodem/hcfpcimodem-1.17.ebuild,v 1.1 2008/09/25 20:55:12 mrness Exp $
+
+inherit eutils linux-info
+
+#The document is the same as in hsfmodem, even if it has a different URL
+MY_DOC="100498D_RM_HxF_Released.pdf"
+
+DESCRIPTION="Linuxant's modem driver for Connexant HCF chipset"
+HOMEPAGE="http://www.linuxant.com/drivers/hcf/index.php"
+SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${P}full.tar.gz
+ doc? ( http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${MY_DOC} )"
+
+LICENSE="Conexant"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ app-arch/cpio"
+
+S="${WORKDIR}/${P}full"
+
+QA_EXECSTACK="usr/lib/hcfpcimodem/modules/imported/hcfblam-i386.O usr/lib/hcfpcimodem/modules/imported/hcfengine-i386.O"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ MOD_N="hcfpci"
+ # Check to see if module is inserted into kernel, otherwise, build fails
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror
+ eerror "Module is in use by the kernel!!!"
+ eerror "Attempting to unload..."
+ eerror
+
+ # Unloading module...
+ ${MOD_N}stop
+ if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
+ eerror "Failed to unload modules from kernel!!!"
+ eerror "Please manualy remove the module from the kernel and emerge again."
+ eerror
+ die
+ fi
+ einfo "Successfuly removed module from memory. Resuming emerge."
+ einfo
+ fi
+}
+
+src_compile() {
+ emake all || die "make failed"
+}
+
+pkg_preinst() {
+ local NVMDIR="${ROOT}/etc/${PN}/nvm"
+ if [ -d "${NVMDIR}" ]; then
+ einfo "Cleaning ${NVMDIR}..."
+ rm -rf "${NVMDIR}"
+ eend
+ fi
+}
+
+src_install () {
+ make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
+
+ # in some cases, kernelcompiler.sh does not have x permission (#173414)
+ fperms a+rx /usr/lib/hcfpcimodem/modules/kernelcompiler.sh
+
+ use doc && dodoc "${DISTDIR}/${MY_DOC}"
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]; then
+ elog "To complete the installation and configuration of your HCF modem,"
+ elog "please run hcfpciconfig."
+ fi
+}
+
+pkg_prerm() {
+ if [ "${ROOT}" = / -a -f /etc/init.d/hcfpci ] ; then
+ hcfpciconfig --remove || die "hcfpciconfig --remove failed"
+ fi
+}