summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/ppp/ppp-2.4.1-r14.ebuild')
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r14.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-dialup/ppp/ppp-2.4.1-r14.ebuild b/net-dialup/ppp/ppp-2.4.1-r14.ebuild
index 0e499fca25bf..5cade6619128 100644
--- a/net-dialup/ppp/ppp-2.4.1-r14.ebuild
+++ b/net-dialup/ppp/ppp-2.4.1-r14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.1-r14.ebuild,v 1.8 2003/09/05 20:51:11 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.1-r14.ebuild,v 1.9 2003/09/07 00:09:22 msterret Exp $
IUSE="crypt ipv6 activefilter"
S=${WORKDIR}/${P}.pppoe4
@@ -44,9 +44,9 @@ src_unpack() {
src_compile() {
cd ${S}
-
+
./configure --prefix=/usr || die
-
+
#fix Makefiles to compile optimized
cd ${S}/pppd
mv Makefile Makefile.orig
@@ -80,9 +80,9 @@ src_compile() {
mv Makefile Makefile.orig
sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
cd ..
-
+
export CC=gcc
-
+
emake || die
}
@@ -92,7 +92,7 @@ src_install() {
doman ${y}/${y}.8
dosbin ${y}/${y}
done
-
+
chmod u+s-w ${D}/usr/sbin/pppd
dodir /etc/ppp/peers
insinto /etc/ppp
@@ -123,7 +123,7 @@ src_install() {
dohtml ${FILESDIR}/pppoe.html
# This has nothing to do with net.ppp0 now as net.ppp0 calls pppd
-# from the command line with the parameters.
+# from the command line with the parameters.
#New scripts acquired from cvs (cvs.samba.org)
#Changed $PATH back
dosbin ${FILESDIR}/pon
@@ -157,8 +157,8 @@ pkg_postinst() {
ewarn "New users or those requiring something more should have a look at"
ewarn "the /etc/init.d/net.ppp0 script."
ewarn "Users needing particular scripts (ssh,rsh,etc.)should check out the"
- ewarn "/usr/share/doc/ppp*/scripts directory."
-}
+ ewarn "/usr/share/doc/ppp*/scripts directory."
+}
pkg_preinst() {
# Fix those broken flags (755 -> 644)