summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/wvdial/wvdial-1.53-r1.ebuild')
-rw-r--r--net-dialup/wvdial/wvdial-1.53-r1.ebuild32
1 files changed, 22 insertions, 10 deletions
diff --git a/net-dialup/wvdial/wvdial-1.53-r1.ebuild b/net-dialup/wvdial/wvdial-1.53-r1.ebuild
index d22e8bc7a16e..1c3cb36edf20 100644
--- a/net-dialup/wvdial/wvdial-1.53-r1.ebuild
+++ b/net-dialup/wvdial/wvdial-1.53-r1.ebuild
@@ -1,14 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.53-r1.ebuild,v 1.6 2003/09/07 00:09:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.53-r1.ebuild,v 1.7 2003/09/12 13:59:18 seemant Exp $
+
+inherit eutils
S=${WORKDIR}/${P}
DESCRIPTION="Excellent program which automatically configures your PPP session"
SRC_URI="http://open.nit.ca/download/${P}.tar.gz"
HOMEPAGE="http://open.nit.ca/"
-DEPEND="net-libs/wvstreams"
-RDEPEND="${DEPEND} net-dialup/ppp"
+DEPEND=">=sys-apps/sed-4
+ net-libs/wvstreams"
+
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
SLOT="0"
LICENSE="LGPL-2"
@@ -18,21 +23,17 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-crypt.patch || die "Patch failed"
+ epatch ${FILESDIR}/${P}-crypt.patch
}
src_compile() {
- cp Makefile Makefile.orig
- sed -e "s:PREFIX=/usr/local:PREFIX=/usr:" \
- Makefile.orig > Makefile
+ sed -i "s:PREFIX=/usr/local:PREFIX=/usr:" Makefile
}
src_install() {
- cp Makefile Makefile.orig
- sed -e "s:PPPDIR=/etc/ppp/peers:PPPDIR=${D}/etc/ppp/peers:" \
- Makefile.orig > Makefile
+ sed -i "s:PPPDIR=/etc/ppp/peers:PPPDIR=${D}/etc/ppp/peers:" Makefile
make \
PREFIX=${D}/usr \
@@ -41,3 +42,14 @@ src_install() {
dodoc ANNOUNCE CHANGES COPYING.LIB README
dodoc debian/copyright debian/changelog
}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Use wvdialconf to automagically generate a configuration-file."
+ einfo
+ einfo "Users have to be member of the dialout AND the uucp group"
+ einfo "to use wvdial!"
+ einfo
+}
+