summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/arptables/arptables-0.0.3.ebuild')
-rw-r--r--net-firewall/arptables/arptables-0.0.3.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/net-firewall/arptables/arptables-0.0.3.ebuild b/net-firewall/arptables/arptables-0.0.3.ebuild
index 7a8d9e73c590..7c0db5c950f9 100644
--- a/net-firewall/arptables/arptables-0.0.3.ebuild
+++ b/net-firewall/arptables/arptables-0.0.3.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/arptables-0.0.3.ebuild,v 1.1 2004/02/28 09:33:02 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/arptables/arptables-0.0.3.ebuild,v 1.1.1.1 2005/11/30 10:11:18 chriswhite Exp $
EXT=-2
-DESCRIPTION="Arptables is used to set up, maintain, and inspect the tables of ARP rules in the Linux kernel. It is analogous to iptables, but operates at the ARP layer rather than the IP layer."
+DESCRIPTION="set up, maintain, and inspect the tables of ARP rules in the Linux kernel"
+HOMEPAGE="http://ebtables.sourceforge.net/"
SRC_URI="mirror://sourceforge/ebtables/${PN}-v${PV}${EXT}.tar.gz"
-HOMEPAGE=""
-KEYWORDS="~x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
-S=${WORKDIR}/${PN}-v${PV}${EXT}/
-
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${PN}-v${PV}${EXT}
src_compile() {
- cd ${S}
- emake
+ emake || die
}
src_install() {
- dodir /sbin/
- einstall PREFIX=${D}/ MANDIR=${D}/usr/share/man/
+ dodir /sbin
+ einstall PREFIX=${D}/ MANDIR=${D}/usr/share/man/ || die
}