summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild')
-rw-r--r--net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild37
1 files changed, 21 insertions, 16 deletions
diff --git a/net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild b/net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild
index 6975a1c0498b..b4d0b5870d5a 100644
--- a/net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild
+++ b/net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild
@@ -1,38 +1,43 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild,v 1.6 2002/07/11 06:30:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ftpfs/ftpfs-0.6.2-r2.ebuild,v 1.7 2002/07/17 09:52:23 seemant Exp $
-A=${P}-k2.4.tar.gz
-S=${WORKDIR}/${P}-k2.4
+MY_P=${P}-k2.4
+S=${WORKDIR}/${MY_P}
DESCRIPTION="A filesystem for mounting FTP volumes"
-SRC_URI="http://ftp1.sourceforge.net/ftpfs/${A}"
+SRC_URI="http://ftp1.sourceforge.net/ftpfs/${MY_P}.tar.gz"
HOMEPAGE="http://ftpfs.sourceforge.net"
+
+SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="x86"
-DEPEND="virtual/glibc
- virtual/linux-sources
- >=sys-apps/portage-1.9.10"
+DEPEND="virtual/linux-sources
+ >=sys-apps/portage-1.9.10"
src_compile() {
check_KV
cd ftpfs
- try make
+ make || die
cd ../ftpmount
- try make CFLAGS="${CFLAGS}"
+ make CFLAGS="${CFLAGS}" || die
}
src_install() {
mv ftpfs/Makefile ftpfs/Makefile.old
- cat ftpfs/Makefile.old |sed s:"depmod -aq"::g > ftpfs/Makefile
- try make MODULESDIR=${D}/lib/modules/${KV} FTPMOUNT=${D}/usr/bin/ftpmount install
+ sed s:"depmod -aq"::g \
+ ftpfs/Makefile.old > ftpfs/Makefile
+
+ make \
+ MODULESDIR=${D}/lib/modules/${KV} \
+ FTPMOUNT=${D}/usr/bin/ftpmount \
+ install || die
+
dodoc CHANGELOG
- docinto html
- dodoc docs/*.html
- docinto html/img
- dodoc docs/img/*
+ dohtml -r docs
}
pkg_postinst() {
echo "running depmod...."
- try depmod -aq
+ depmod -aq || die
}