summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/intersync/intersync-0.9.5_p2.ebuild')
-rw-r--r--net-fs/intersync/intersync-0.9.5_p2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-fs/intersync/intersync-0.9.5_p2.ebuild b/net-fs/intersync/intersync-0.9.5_p2.ebuild
new file mode 100644
index 000000000000..1807e6530191
--- /dev/null
+++ b/net-fs/intersync/intersync-0.9.5_p2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/intersync/intersync-0.9.5_p2.ebuild,v 1.1 2003/08/10 20:35:21 karltk Exp $
+
+DESCRIPTION="Intermezzo is an advanced replicating networked filesystem."
+HOMEPAGE="http://www.inter-mezzo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="net-ftp/curl
+ media-gfx/transfig
+ >=dev-libs/glib-2*
+ >=gnome-base/libghttp-1.0.9-r3
+ >=sys-kernel/linux-headers-2.4"
+
+SRC_URI="ftp://ftp.inter-mezzo.org/pub/intermezzo/${P/_p/-}.tar.gz"
+S=${WORKDIR}/${P/_p?/}
+
+src_compile () {
+ local myconf=""
+ has "net-www/apache" \
+ && $myconf="${myconf} --with-apache-modules=/etc/apache/modules"
+
+ ./configure \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --datadir=/usr/share \
+ --libdir=/lib \
+ ${myconf}
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/intersync.rc intersync
+ insinto /etc/conf.d ; newins ${FILESDIR}/intersync.conf intersync
+}