summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog8
-rw-r--r--net-im/gaim/Manifest8
-rw-r--r--net-im/gaim/files/digest-gaim-1.1.3-r11
-rw-r--r--net-im/gaim/gaim-1.1.3-r1.ebuild133
4 files changed, 146 insertions, 4 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index e46df7e9f1c2..a36ddd6eb5ef 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.301 2005/02/21 03:58:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.302 2005/02/21 19:30:08 rizzo Exp $
+
+*gaim-1.1.3-r1 (21 Feb 2005)
+
+ 21 Feb 2005; Don Seiler <rizzo@gentoo.org> +gaim-1.1.3-r1.ebuild:
+ Adding krb4 support with a check to ensure krb4 support in mit-krb5. Closes
+ bug #82401. Thanks Ben Gelb
20 Feb 2005; Aron Griffis <agriffis@gentoo.org> gaim-1.1.3.ebuild:
stable on ia64 #82450
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 19943593b992..b886ff4b3283 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,7 +1,9 @@
-MD5 0af3b32b8e049a3361208eee7b701724 gaim-1.1.3.ebuild 3638
-MD5 8ee86b531b08047e75a4db5671eb9395 gaim-1.1.2.ebuild 3633
MD5 32cd742709c26726ac2d0fc60fd545b9 ChangeLog 45339
+MD5 8ee86b531b08047e75a4db5671eb9395 gaim-1.1.2.ebuild 3633
MD5 19b3cafbbe380403d46cccc45a984b80 metadata.xml 481
+MD5 7b10cf71371ae3bb0fe465271eed2fce gaim-1.1.3-r1.ebuild 3887
+MD5 0af3b32b8e049a3361208eee7b701724 gaim-1.1.3.ebuild 3638
MD5 63540ba1527c8935186ff9fd54d166a5 files/digest-gaim-1.1.2 64
-MD5 e33ebae8e6ff204c3fdce739b35d426c files/digest-gaim-1.1.3 64
MD5 afc682711efed5d09a9229bd06a7a13b files/gaim-0.76-xinput.patch 644
+MD5 e33ebae8e6ff204c3fdce739b35d426c files/digest-gaim-1.1.3 64
+MD5 e33ebae8e6ff204c3fdce739b35d426c files/digest-gaim-1.1.3-r1 64
diff --git a/net-im/gaim/files/digest-gaim-1.1.3-r1 b/net-im/gaim/files/digest-gaim-1.1.3-r1
new file mode 100644
index 000000000000..78f4b82469ca
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-1.1.3-r1
@@ -0,0 +1 @@
+MD5 4934cf3e45c763a6f71d03f59db935e2 gaim-1.1.3.tar.bz2 5197132
diff --git a/net-im/gaim/gaim-1.1.3-r1.ebuild b/net-im/gaim/gaim-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..c3cf7d96edde
--- /dev/null
+++ b/net-im/gaim/gaim-1.1.3-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-1.1.3-r1.ebuild,v 1.1 2005/02/21 19:30:08 rizzo Exp $
+
+inherit flag-o-matic eutils gcc debug
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls perl spell nas cjk gnutls silc eds krb4 debug"
+
+DEPEND=">=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ dev-util/pkgconfig
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.8.2-r1
+ !<dev-perl/ExtUtils-MakeMaker-6.17 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.9.2-r2 )
+ silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
+ eds? ( gnome-extra/evolution-data-server )
+ krb4? ( >=app-crypt/mit-krb5-1.3.6-r1 )"
+
+# List of plugins
+# app-accessibility/festival-gaim
+# net-im/gaim-blogger
+# net-im/gaim-bnet
+# net-im/gaim-meanwhile
+# net-im/gaim-snpp
+# x11-plugins/autoprofile
+# x11-plugins/gaim-assistant
+# x11-plugins/gaim-encryption
+# x11-plugins/gaim-extprefs
+# x11-plugins/gaim-otr
+# x11-plugins/gaim-rhythmbox
+# x11-plugins/gaim-xmms-remote
+# x11-plugins/gaimosd
+# x11-plugins/guifications
+
+
+print_gaim_warning() {
+ ewarn
+ ewarn "If you are merging ${P} from an earlier version, you will need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ einfo
+ einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
+ einfo
+ ebeep 5
+ epause 3
+}
+
+pkg_setup() {
+ print_gaim_warning
+ if use krb4 && ! built_with_use mit-krb5 krb4 ; then
+ eerror
+ eerror You need to rebuild app-crypt/mit-krb5 with USE=krb4 in order to
+ eerror enable krb4 support for the zephyr protocol in gaim.
+ eerror
+ die "Configure failed"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use cjk && epatch ${FILESDIR}/gaim-0.76-xinput.patch
+}
+
+src_compile() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+ use debug && myconf="${myconf} --enable-debug"
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ use eds || myconf="${myconf} --disable-gevolution"
+ use krb4 && myconf="${myconf} --with-krb4"
+
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/lib"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no"
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+ myconf="${myconf} --with-nspr-libs=/usr/lib/nspr"
+ myconf="${myconf} --with-nss-libs=/usr/lib/nss"
+ fi
+
+
+ econf ${myconf} || die "Configuration failed"
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ print_gaim_warning
+}