summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh/ChangeLog7
-rw-r--r--net-libs/libssh/libssh-0.3.4.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/net-libs/libssh/ChangeLog b/net-libs/libssh/ChangeLog
index c980dfc6f847..613b9fa0b405 100644
--- a/net-libs/libssh/ChangeLog
+++ b/net-libs/libssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/ChangeLog,v 1.13 2009/08/26 02:34:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/ChangeLog,v 1.14 2009/09/29 00:57:46 jer Exp $
+
+*libssh-0.3.4 (29 Sep 2009)
+
+ 29 Sep 2009; Jeroen Roovers <jer@gentoo.org> +libssh-0.3.4.ebuild:
+ Version bump thanks to Thomas Beinicke (bug #286860).
*libssh-0.3.3 (26 Aug 2009)
diff --git a/net-libs/libssh/libssh-0.3.4.ebuild b/net-libs/libssh/libssh-0.3.4.ebuild
new file mode 100644
index 000000000000..b18c5630f088
--- /dev/null
+++ b/net-libs/libssh/libssh-0.3.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/libssh-0.3.4.ebuild,v 1.1 2009/09/29 00:57:46 jer Exp $
+
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="http://www.libssh.org/"
+SRC_URI="http://www.libssh.org/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+SLOT="0"
+IUSE="debug gcrypt examples +sftp ssh1 server static-libs zlib"
+
+DEPEND="
+ zlib? ( >=sys-libs/zlib-1.2 )
+ !gcrypt? ( >=dev-libs/openssl-0.9.8 )
+ gcrypt? ( >=dev-libs/libgcrypt-1.4 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-automagic-crypt.patch"
+)
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with debug DEBUG_CRYPTO)
+ $(cmake-utils_use_with gcrypt)
+ $(cmake-utils_use_with zlib LIBZ)
+ $(cmake-utils_use_with sftp)
+ $(cmake-utils_use_with ssh1)
+ $(cmake-utils_use_with server)
+ $(cmake-utils_use_with static-libs STATIC_LIB)
+ "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples; then
+ insinto "${ROOT}"usr/share/doc/"${PF}"/examples
+ doins sample.c samplesshd.c
+ fi
+}