summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild')
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild
index 28039a6e56ee..b236da79b769 100644
--- a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild,v 1.1 2007/07/21 17:27:10 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.2.13.ebuild,v 1.2 2007/07/28 15:39:48 dertobi123 Exp $
-inherit perl-app eutils
+inherit autotools perl-app eutils
DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
@@ -32,21 +32,15 @@ S="${WORKDIR}/cyrus-imapd-${PV}"
src_unpack() {
unpack ${A} && cd "${S}"
- # DB4 detection and versioned symbols.
- #epatch "${FILESDIR}/cyrus-imapd-${PV}-db4.patch"
-
- # Recreate configure.
- export WANT_AUTOCONF="2.5"
- ebegin "Recreating configure"
- rm -rf configure config.h.in autom4te.cache
- sh SMakefile &>/dev/null || die "SMakefile failed"
- eend $?
-
# When linking with rpm, you need to link with more libraries.
sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
epatch "${FILESDIR}/${PN}-2.2-db45.patch"
epatch "${FILESDIR}/${PN}-2.2-fPIC.patch"
+
+ # Recreate configure.
+ WANT_AUTOCONF="2.5"
+ eautoreconf
}
src_compile() {