summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/fetchyahoo/fetchyahoo-2.13.6.ebuild')
-rw-r--r--net-mail/fetchyahoo/fetchyahoo-2.13.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/fetchyahoo/fetchyahoo-2.13.6.ebuild b/net-mail/fetchyahoo/fetchyahoo-2.13.6.ebuild
new file mode 100644
index 000000000000..ad58a59382a6
--- /dev/null
+++ b/net-mail/fetchyahoo/fetchyahoo-2.13.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchyahoo/fetchyahoo-2.13.6.ebuild,v 1.1 2009/07/11 14:23:57 dertobi123 Exp $
+
+IUSE=""
+DESCRIPTION="Download mail from a Yahoo! webmail account to a local mail spool, an mbox file, or to procmail."
+MY_P=${P/_alpha/alpha}
+SRC_URI="http://fetchyahoo.twizzler.org/${MY_P}.tar.gz"
+HOMEPAGE="http://fetchyahoo.twizzler.org/"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+
+DEPEND="dev-lang/perl
+ dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/MIME-tools
+ virtual/perl-libnet
+ dev-perl/Crypt-SSLeay
+ dev-perl/URI
+ dev-perl/MailTools
+ dev-perl/IO-stringy
+ virtual/perl-MIME-Base64
+ dev-perl/TermReadKey"
+
+src_install() {
+ dobin fetchyahoo || die
+ doman fetchyahoo.1 || die
+ insinto /etc
+ doins fetchyahoorc || die
+ dodoc ChangeLog Credits INSTALL TODO fetchyahoorc || die
+ dohtml index.html || die
+}
+
+pkg_postinst() {
+ elog "Edit /etc/fetchyahoorc or ~/.fetchyahoorc to configure fetchyahoo"
+ elog "The executable name has changed from fetchyahoo.pl to fetchyahoo"
+}