summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild')
-rw-r--r--net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild b/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild
index 03e48b596a7c..ee28b9f5a905 100644
--- a/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild
+++ b/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild,v 1.1 2011/05/02 22:21:32 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild,v 1.2 2011/05/02 22:37:34 tampakrap Exp $
-inherit perl-app
+EAPI=4
-IUSE=""
-
-SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
-RESTRICT="mirror"
+inherit perl-module
DESCRIPTION="Perl Mail-to-HTML Converter, Gentoo fork"
HOMEPAGE="http://www.mhonarc.org/"
LICENSE="GPL-2"
+SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
RDEPEND="!net-mail/mhonarc"
-S="${WORKDIR}/${P/mhonarc-gentoo/MHonArc}"
+MY_P="${P/mhonarc-gentoo/MHonArc}"
+S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-archives-gentoo.patch
-}
+PATCHES=( "${FILESDIR}/${P}-archives-gentoo.patch" )
src_install() {
sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}' -prefix '${D}'|g" -i Makefile
sed -e "s|installsitelib|installvendorlib|g" -i install.me
+
perl-module_src_install
- prepalldocs
}