summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/vmailmgr')
-rw-r--r--net-mail/vmailmgr/ChangeLog12
-rw-r--r--net-mail/vmailmgr/files/vmailmgr-0.97-strcasestr.patch43
-rw-r--r--net-mail/vmailmgr/vmailmgr-0.97-r1.ebuild (renamed from net-mail/vmailmgr/vmailmgr-0.97.ebuild)12
3 files changed, 59 insertions, 8 deletions
diff --git a/net-mail/vmailmgr/ChangeLog b/net-mail/vmailmgr/ChangeLog
index e00b4a142ecb..ebd43684c256 100644
--- a/net-mail/vmailmgr/ChangeLog
+++ b/net-mail/vmailmgr/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/vmailmgr
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/ChangeLog,v 1.30 2008/06/22 22:18:05 mrness Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/ChangeLog,v 1.31 2009/06/20 11:09:36 mrness Exp $
+
+*vmailmgr-0.97-r1 (20 Jun 2009)
+
+ 20 Jun 2009; Alin Năstac <mrness@gentoo.org>
+ +files/vmailmgr-0.97-strcasestr.patch, -vmailmgr-0.97.ebuild,
+ +vmailmgr-0.97-r1.ebuild:
+ Define strcasestr() only when is not declared in string.h (#273270). Migrate
+ to EAPI 2.
22 Jun 2008; Alin Năstac <mrness@gentoo.org>
files/vmailmgr-0.97-gentoo.patch,
diff --git a/net-mail/vmailmgr/files/vmailmgr-0.97-strcasestr.patch b/net-mail/vmailmgr/files/vmailmgr-0.97-strcasestr.patch
new file mode 100644
index 000000000000..e2cf6234ca27
--- /dev/null
+++ b/net-mail/vmailmgr/files/vmailmgr-0.97-strcasestr.patch
@@ -0,0 +1,43 @@
+diff -Nru vmailmgr-0.97.orig/authenticate/checkvpw.cc vmailmgr-0.97/authenticate/checkvpw.cc
+--- vmailmgr-0.97.orig/authenticate/checkvpw.cc 2002-11-20 16:54:49.000000000 +0100
++++ vmailmgr-0.97/authenticate/checkvpw.cc 2009-06-20 12:56:27.000000000 +0200
+@@ -105,6 +105,7 @@
+ return new auth_data(name, pass, stamp);
+ }
+
++#ifndef HAVE_STRCASESTR
+ char* strcasestr(const char* haystack, const char* needle)
+ {
+ for(size_t hlength = strlen(haystack), nlength = strlen(needle);
+@@ -113,6 +114,7 @@
+ return (char*)haystack;
+ return 0;
+ }
++#endif /* HAVE_STRCASESTR */
+
+ unsigned find_maildir(int argc, const char* args[])
+ {
+diff -Nru vmailmgr-0.97.orig/config.h.in vmailmgr-0.97/config.h.in
+--- vmailmgr-0.97.orig/config.h.in 2009-06-20 12:58:25.000000000 +0200
++++ vmailmgr-0.97/config.h.in 2009-06-20 12:55:32.000000000 +0200
+@@ -16,6 +16,9 @@
+ #undef VPWTABLE_CDB
+ #undef VPWTABLE_GDBM
+
++/* Define to 1 if you have the `strcasestr' function. */
++#undef HAVE_STRCASESTR
++
+ /* Define to 1 if you have the `crypt' function. */
+ #undef HAVE_CRYPT
+
+diff -Nru vmailmgr-0.97.orig/configure.in vmailmgr-0.97/configure.in
+--- vmailmgr-0.97.orig/configure.in 2009-06-20 12:58:17.000000000 +0200
++++ vmailmgr-0.97/configure.in 2009-06-20 12:55:09.000000000 +0200
+@@ -112,6 +112,7 @@
+ dnl Checks for library functions.
+ AC_CHECK_FUNCS(gethostname gettimeofday mkdir putenv rmdir socket)
+ AC_CHECK_FUNCS(srandom random crypt)
++AC_CHECK_FUNCS(strcasestr)
+
+ cgidir='/var/www/localhost/cgi-bin'
+ AC_SUBST(cgidir)
diff --git a/net-mail/vmailmgr/vmailmgr-0.97.ebuild b/net-mail/vmailmgr/vmailmgr-0.97-r1.ebuild
index 69017386119b..eccf8008c19a 100644
--- a/net-mail/vmailmgr/vmailmgr-0.97.ebuild
+++ b/net-mail/vmailmgr/vmailmgr-0.97-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.97.ebuild,v 1.9 2008/06/22 22:18:05 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vmailmgr/vmailmgr-0.97-r1.ebuild,v 1.1 2009/06/20 11:09:36 mrness Exp $
+
+EAPI="2"
inherit toolchain-funcs eutils autotools
@@ -18,11 +20,9 @@ RDEPEND=">=sys-apps/ucspi-unix-0.34
virtual/qmail
>=net-mail/qmail-autoresponder-0.95"
-src_unpack() {
- unpack ${A}
-
- cd "${S}" || die "source dir not found"
+src_prepare() {
epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-strcasestr.patch"
eautoreconf
}