summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cfengine')
-rw-r--r--net-misc/cfengine/ChangeLog10
-rw-r--r--net-misc/cfengine/cfengine-3.2.4.ebuild (renamed from net-misc/cfengine/cfengine-3.1.5.ebuild)24
2 files changed, 18 insertions, 16 deletions
diff --git a/net-misc/cfengine/ChangeLog b/net-misc/cfengine/ChangeLog
index 44fffc314146..6a0f3e104d1c 100644
--- a/net-misc/cfengine/ChangeLog
+++ b/net-misc/cfengine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/cfengine
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.140 2011/11/01 22:27:01 idl0r Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.141 2012/02/12 18:47:10 idl0r Exp $
+
+*cfengine-3.2.4 (12 Feb 2012)
+
+ 12 Feb 2012; Christian Ruppert <idl0r@gentoo.org> -cfengine-3.1.5.ebuild,
+ +cfengine-3.2.4.ebuild:
+ Version bump.
*cfengine-3.2.3 (01 Nov 2011)
diff --git a/net-misc/cfengine/cfengine-3.1.5.ebuild b/net-misc/cfengine/cfengine-3.2.4.ebuild
index e24b2a2f2811..d9de35c169d8 100644
--- a/net-misc/cfengine/cfengine-3.1.5.ebuild
+++ b/net-misc/cfengine/cfengine-3.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.1.5.ebuild,v 1.2 2011/08/30 17:11:03 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-3.2.4.ebuild,v 1.1 2012/02/12 18:47:10 idl0r Exp $
EAPI="3"
@@ -11,7 +11,7 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="An automated suite of programs for configuring and maintaining
Unix-like computers"
HOMEPAGE="http://www.cfengine.org/"
-SRC_URI="http://cfengine.com/source_code/download?file=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+SRC_URI="http://cfengine.com/source-code/download?file=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="3"
@@ -38,13 +38,8 @@ S="${WORKDIR}/${MY_P}"
src_configure() {
local myconf
- if use mysql || use postgres ; then
- myconf="--with-sql"
- else
- myconf="--without-sql"
- fi
-
# BDB by default, prefer tokyocabinet above qdbm...
+ # sqlite3 has been added but stated as experimental/broken...
if ! use qdbm && ! use tokyocabinet; then
myconf="${myconf} --with-berkeleydb=/usr"
elif use qdbm && use tokyocabinet; then
@@ -63,10 +58,12 @@ src_configure() {
--with-workdir=/var/cfengine \
--with-pcre \
${myconf} \
+ $(use_with postgres postgresql) \
+ $(use_with mysql) \
$(use_enable selinux)
# Fix Makefile to skip inputs, see below "examples"
- sed -i -e 's/\(SUBDIRS.*\) inputs/\1/' Makefile || die
+ #sed -i -e 's/\(SUBDIRS.*\) inputs/\1/' Makefile || die
# We install documentation through portage
sed -i -e 's/\(install-data-am.*\) install-docDATA/\1/' Makefile || die
@@ -78,11 +75,10 @@ src_install() {
newinitd "${FILESDIR}"/cf-execd.rc6 cf-execd || die
emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO INSTALL
+ dodoc AUTHORS ChangeLog README INSTALL
- if use examples; then
- docinto examples
- dodoc inputs/*.cf || die
+ if ! use examples; then
+ rm -rf "${D}"/usr/share/doc/${PF}/example*
fi
# Create cfengine working directory