summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/icecast/icecast-1.3.12-r1.ebuild')
-rw-r--r--net-misc/icecast/icecast-1.3.12-r1.ebuild43
1 files changed, 17 insertions, 26 deletions
diff --git a/net-misc/icecast/icecast-1.3.12-r1.ebuild b/net-misc/icecast/icecast-1.3.12-r1.ebuild
index c0b3f14c2e7a..25be37652079 100644
--- a/net-misc/icecast/icecast-1.3.12-r1.ebuild
+++ b/net-misc/icecast/icecast-1.3.12-r1.ebuild
@@ -1,46 +1,38 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-1.3.12-r1.ebuild,v 1.4 2003/01/09 21:29:05 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Icecast is an Internet based broadcasting system based on the Mpeg Layer III streaming technology."
+DESCRIPTION="Internet based broadcasting system based on the mpeg3 streaming technology"
SRC_URI="http://www.icecast.org/releases/${P}.tar.gz"
-HOMEPAGE="http://www.icecast.org"
-KEYWORDS="x86 -ppc -sparc "
+HOMEPAGE="http://www.icecast.org/"
+
+KEYWORDS="x86 -ppc sparc"
LICENSE="GPL-2"
SLOT="0"
+IUSE="crypt"
DEPEND="virtual/glibc"
src_unpack() {
-
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/variables.diff
-
+ patch -p1 < ${FILESDIR}/variables.diff || die
}
src_compile() {
-
- local myconf
-
- use crypt && myconf="--with-crypt" || myconf="--without-crypt"
-
- ./configure --with-libwrap \
- ${myconf} \
- --prefix=/usr \
- --sysconfdir=/etc/icecast \
- --localstatedir=/var \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --host=${CHOST} || die "configure failed"
-
+ ./configure \
+ `use_with crypt` \
+ --with-libwrap \
+ --prefix=/usr \
+ --sysconfdir=/etc/icecast \
+ --localstatedir=/var \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die "configure failed"
emake || die "emake failed"
}
-
-src_install () {
-
+src_install() {
make DESTDIR=${D} \
ICECAST_BINDIR=/usr/bin \
ICECAST_DOCDIR=/usr/share/doc/${P} \
@@ -54,6 +46,5 @@ src_install () {
ICECAST_TEMPLATEDIR=/usr/share/icecast/templates \
ICECAST_TEMPLATEDIR_INST=/usr/share/icecast/templates \
install || die "make install failed"
-
dodoc AUTHORS BUGS CHANGES COPYING FAQ INSTALL README TESTED TODO
}