summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openswan/files/openswan-2.3.0-gentoo.patch')
-rw-r--r--net-misc/openswan/files/openswan-2.3.0-gentoo.patch434
1 files changed, 434 insertions, 0 deletions
diff --git a/net-misc/openswan/files/openswan-2.3.0-gentoo.patch b/net-misc/openswan/files/openswan-2.3.0-gentoo.patch
new file mode 100644
index 000000000000..392f168a9dc5
--- /dev/null
+++ b/net-misc/openswan/files/openswan-2.3.0-gentoo.patch
@@ -0,0 +1,434 @@
+diff -Naupr openswan-2.3.0/Makefile.inc openswan-2.3.0-gentoo/Makefile.inc
+--- openswan-2.3.0/Makefile.inc 2004-12-31 18:52:53.000000000 -0600
++++ openswan-2.3.0-gentoo/Makefile.inc 2005-01-20 20:24:20.384146880 -0600
+@@ -65,7 +65,7 @@ POLICYLIB=${OPENSWANSRCDIR}/lib/libipsec
+ DESTDIR?=
+
+ # "local" part of tree, used in building other pathnames
+-INC_USRLOCAL=/usr/local
++INC_USRLOCAL=/usr
+
+ # PUBDIR is where the "ipsec" command goes; beware, many things define PATH
+ # settings which are assumed to include it (or at least, to include *some*
+@@ -99,7 +99,7 @@ MANTREE=$(DESTDIR)$(INC_USRLOCAL)/$(INC_
+ MANPLACES=man3 man5 man8
+
+ # where configuration files go
+-FINALCONFFILE?=/etc/ipsec.conf
++FINALCONFFILE?=/etc/ipsec/ipsec.conf
+ CONFFILE=$(DESTDIR)$(FINALCONFFILE)
+
+ FINALCONFDIR?=/etc
+@@ -110,10 +110,10 @@ CONFDDIR=$(DESTDIR)$(FINALCONFDDIR)
+
+ # sample configuration files go into
+ INC_DOCDIR?=share/doc
+-FINALEXAMPLECONFDIR=${INC_USRLOCAL}/${INC_DOCDIR}/openswan
++FINALEXAMPLECONFDIR=${INC_USRLOCAL}/${INC_DOCDIR}/openswan-2.3.0
+ EXAMPLECONFDIR=${DESTDIR}${FINALEXAMPLECONFDIR}
+
+-FINALDOCDIR?=${INC_USRLOCAL}/${INC_DOCDIR}/openswan
++FINALDOCDIR?=${INC_USRLOCAL}/${INC_DOCDIR}/openswan-2.3.0
+ DOCDIR=${DESTDIR}${FINALDOCDIR}
+
+ # where per-conn pluto logs go
+@@ -247,7 +247,7 @@ RH_KERNELSRC?=/usr/src/linux-2.4
+ # installed one in RH 7.2, won't work - you wind up depending upon
+ # openssl.
+
+-BIND9STATICLIBDIR?=/usr/local/lib
++BIND9STATICLIBDIR?=/usr/lib
+
+ # if you install elsewere, you may need to point the include files to it.
+ #BIND9STATICLIBDIR?=/sandel/lib
+diff -Naupr openswan-2.3.0/doc/Makefile openswan-2.3.0-gentoo/doc/Makefile
+--- openswan-2.3.0/doc/Makefile 2004-09-18 13:59:18.000000000 -0500
++++ openswan-2.3.0-gentoo/doc/Makefile 2005-01-20 20:25:36.702578773 -0600
+@@ -1,6 +1,6 @@
+ # Makefile to generate various formats from HTML source
+ #
+-# Assumes the htmldoc utility is available.
++# No longer cares if the htmldoc utility is available.
+ # This can be downloaded from www.easysw.com
+ #
+ # Also needs lynx(1) for HTML-to-text conversion
+@@ -67,28 +67,11 @@ HMANDIR=manpage.d
+ # dependencies build most of it
+ # then we add index
+ index.html: toc.html HowTo.html manpages src/index.html
+- cp src/index.html index.html
+-
+-# separate files plus table of contents
+-# and then remove HTML formatting added by htmldoc
+-toc.html : $(sections)
+- -@htmldoc -t html --path ".;${TESTINGDIR}/doc" -d . $(sections)
+- @$(SCRIPTDIR)/cleanhtml.sh $(SCRIPTDIR)/cleanhtml.sed $(separate)
+-
+-# one big HTML file
+-HowTo.html : $(sections)
+- -@htmldoc -t html --toclevels 4 --header ' cf' -f $@ $(sections)
+
+ # other HowTo formats
+ HowTo.txt: HowTo.html
+ lynx -dump $< > $@
+
+-HowTo.ps : $(sections)
+- -@htmldoc -f $@ $(sections)
+-
+-HowTo.pdf : $(sections)
+- -@htmldoc -f $@ $(sections)
+-
+ manpages: manp
+
+ manp: $(SCRIPTDIR)/mkhtmlman
+diff -Naupr openswan-2.3.0/lib/libcrypto/libdes/Makefile openswan-2.3.0-gentoo/lib/libcrypto/libdes/Makefile
+--- openswan-2.3.0/lib/libcrypto/libdes/Makefile 2004-07-15 19:25:17.000000000 -0500
++++ openswan-2.3.0-gentoo/lib/libcrypto/libdes/Makefile 2005-01-20 20:24:20.385146703 -0600
+@@ -60,7 +60,7 @@ MAKE=make -f Makefile
+ # normally overridden by FreeS/WAN Makefiles anyway
+ CFLAG= -O3 -fomit-frame-pointer -I${KLIPSD}/include -I${SRCDIR}
+
+-CFLAGS=$(OPTS) $(CFLAG)
++CFLAGS=$(OPTS) $(CFLAG) $(USERCOMPILE)
+ CPP=$(CC) -E
+
+ # Assember version of des_encrypt*().
+diff -Naupr openswan-2.3.0/lib/libcrypto/libdes/asm/crypt586.pl openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/crypt586.pl
+--- openswan-2.3.0/lib/libcrypto/libdes/asm/crypt586.pl 2004-07-15 19:24:45.000000000 -0500
++++ openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/crypt586.pl 2005-01-20 20:24:20.385146703 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+ #
+ # The inner loop instruction sequence and the IP/FP modifications are from
+ # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
+diff -Naupr openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/cbc.pl openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/cbc.pl
+--- openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/cbc.pl 2004-07-10 03:07:06.000000000 -0500
++++ openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/cbc.pl 2005-01-20 20:24:20.385146703 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ # void des_ncbc_encrypt(input, output, length, schedule, ivec, enc)
+ # des_cblock (*input);
+diff -Naupr openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/x86asm.pl openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/x86asm.pl
+--- openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/x86asm.pl 2004-07-10 03:07:06.000000000 -0500
++++ openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/x86asm.pl 2005-01-20 20:24:20.386146525 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ # require 'x86asm.pl';
+ # &asm_init("cpp","des-586.pl");
+diff -Naupr openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/x86ms.pl openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/x86ms.pl
+--- openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/x86ms.pl 2004-07-10 03:07:07.000000000 -0500
++++ openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/x86ms.pl 2005-01-20 20:24:20.386146525 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ package x86ms;
+
+diff -Naupr openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/x86unix.pl openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/x86unix.pl
+--- openswan-2.3.0/lib/libcrypto/libdes/asm/perlasm/x86unix.pl 2004-07-10 03:07:07.000000000 -0500
++++ openswan-2.3.0-gentoo/lib/libcrypto/libdes/asm/perlasm/x86unix.pl 2005-01-20 20:24:20.386146525 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ package x86unix;
+
+diff -Naupr openswan-2.3.0/lib/liblwres/Makefile openswan-2.3.0-gentoo/lib/liblwres/Makefile
+--- openswan-2.3.0/lib/liblwres/Makefile 2004-11-16 16:11:54.000000000 -0600
++++ openswan-2.3.0-gentoo/lib/liblwres/Makefile 2005-01-20 20:24:20.387146347 -0600
+@@ -24,7 +24,7 @@ CINCLUDES = -I${srcdir}/unix/include \
+ CDEFINES = -g
+ CWARNINGS = -Werror
+
+-CFLAGS=${CINCLUDES} ${CDEFINES} ${CWARNINGS}
++CFLAGS=${CINCLUDES} ${CDEFINES} ${CWARNINGS} $(USERCOMPILE)
+
+ VERSION="@(\#) openswan-hacking-9.3-for-osw2"
+ LIBINTERFACE=2
+diff -Naupr openswan-2.3.0/linux/net/ipsec/des/asm/des-586.pl openswan-2.3.0-gentoo/linux/net/ipsec/des/asm/des-586.pl
+--- openswan-2.3.0/linux/net/ipsec/des/asm/des-586.pl 2004-07-10 03:06:50.000000000 -0500
++++ openswan-2.3.0-gentoo/linux/net/ipsec/des/asm/des-586.pl 2005-01-20 20:24:20.387146347 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+ #
+ # The inner loop instruction sequence and the IP/FP modifications are from
+ # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
+diff -Naupr openswan-2.3.0/linux/net/ipsec/des/asm/des686.pl openswan-2.3.0-gentoo/linux/net/ipsec/des/asm/des686.pl
+--- openswan-2.3.0/linux/net/ipsec/des/asm/des686.pl 2004-07-10 03:06:50.000000000 -0500
++++ openswan-2.3.0-gentoo/linux/net/ipsec/des/asm/des686.pl 2005-01-20 20:24:20.387146347 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ $prog="des686.pl";
+
+diff -Naupr openswan-2.3.0/linux/net/ipsec/des/asm/desboth.pl openswan-2.3.0-gentoo/linux/net/ipsec/des/asm/desboth.pl
+--- openswan-2.3.0/linux/net/ipsec/des/asm/desboth.pl 2004-07-10 03:06:50.000000000 -0500
++++ openswan-2.3.0-gentoo/linux/net/ipsec/des/asm/desboth.pl 2005-01-20 20:24:20.388146169 -0600
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+
+ $L="edi";
+ $R="esi";
+diff -Naupr openswan-2.3.0/programs/_include/_include.in openswan-2.3.0-gentoo/programs/_include/_include.in
+--- openswan-2.3.0/programs/_include/_include.in 2003-01-06 15:44:04.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/_include/_include.in 2005-01-20 20:24:20.388146169 -0600
+@@ -47,10 +47,10 @@ for f
+ do
+ if test ! -r "$f"
+ then
+- if test ! "$f" = "/etc/ipsec.conf"
++ if test ! "$f" = "/etc/ipsec/ipsec.conf"
+ then
+ echo "#:cannot open configuration file \'$f\'"
+- if test "$f" = "/etc/ipsec.secrets"
++ if test "$f" = "/etc/ipsec/ipsec.secrets"
+ then
+ echo "#:Your secrets file will be created when you start FreeS/WAN for the first time."
+ fi
+diff -Naupr openswan-2.3.0/programs/barf/barf.in openswan-2.3.0-gentoo/programs/barf/barf.in
+--- openswan-2.3.0/programs/barf/barf.in 2004-12-29 19:59:10.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/barf/barf.in 2005-01-20 20:24:20.388146169 -0600
+@@ -16,7 +16,7 @@
+
+ LOGS=${LOGS-/var/log}
+ CONFS=${IPSEC_CONFS-/etc}
+-CONFDDIR=${IPSEC_CONFDDIR-/etc/ipsec.d}
++CONFDDIR=${IPSEC_CONFDDIR-/etc/ipsec/ipsec.d}
+ me="ipsec barf"
+ # Max lines to use for things like 'route -n'
+ maxlines=100
+@@ -238,13 +238,13 @@ then
+ done
+ fi
+ _________________________ ipsec/ls-libdir
+-ls -l ${IPSEC_LIBDIR-/usr/local/lib/ipsec}
++ls -l ${IPSEC_LIBDIR-/usr/lib/ipsec}
+ _________________________ ipsec/ls-execdir
+-ls -l ${IPSEC_EXECDIR-/usr/local/libexec/ipsec}
++ls -l ${IPSEC_EXECDIR-/usr/libexec/ipsec}
+ _________________________ ipsec/updowns
+-for f in `ls ${IPSEC_EXECDIR-/usr/local/libexec/ipsec} | egrep updown`
++for f in `ls ${IPSEC_EXECDIR-/usr/libexec/ipsec} | egrep updown`
+ do
+- cat ${IPSEC_EXECDIR-/usr/local/libexec/ipsec}/$f
++ cat ${IPSEC_EXECDIR-/usr/libexec/ipsec}/$f
+ done
+ _________________________ /proc/net/dev
+ cat /proc/net/dev
+diff -Naupr openswan-2.3.0/programs/eroute/eroute.5 openswan-2.3.0-gentoo/programs/eroute/eroute.5
+--- openswan-2.3.0/programs/eroute/eroute.5 2003-10-30 20:32:27.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/eroute/eroute.5 2005-01-20 20:24:20.389145992 -0600
+@@ -223,7 +223,7 @@ Parameters Index of
+ in hexadecimal using Authentication Header protocol (51,
+ IPPROTO_AH) with no identies defined for either end.
+ .SH FILES
+-/proc/net/ipsec_eroute, /usr/local/bin/ipsec
++/proc/net/ipsec_eroute, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(5), ipsec_spi(5),
+ ipsec_spigrp(5), ipsec_klipsdebug(5), ipsec_eroute(8), ipsec_version(5),
+diff -Naupr openswan-2.3.0/programs/eroute/eroute.8 openswan-2.3.0-gentoo/programs/eroute/eroute.8
+--- openswan-2.3.0/programs/eroute/eroute.8 2003-10-30 20:32:27.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/eroute/eroute.8 2005-01-20 20:24:20.389145992 -0600
+@@ -308,7 +308,7 @@ will be in clear text.
+ .br
+ .LP
+ .SH FILES
+-/proc/net/ipsec_eroute, /usr/local/bin/ipsec
++/proc/net/ipsec_eroute, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_spi(8),
+ ipsec_spigrp(8), ipsec_klipsdebug(8), ipsec_eroute(5)
+diff -Naupr openswan-2.3.0/programs/ipsec/ipsec.8 openswan-2.3.0-gentoo/programs/ipsec/ipsec.8
+--- openswan-2.3.0/programs/ipsec/ipsec.8 2003-02-27 10:51:54.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/ipsec/ipsec.8 2005-01-20 20:24:20.389145992 -0600
+@@ -81,7 +81,7 @@ reports where
+ .I ipsec
+ thinks the IPsec configuration files are stored.
+ .SH FILES
+-/usr/local/lib/ipsec usual utilities directory
++/usr/lib/ipsec usual utilities directory
+ .SH ENVIRONMENT
+ .PP
+ The following environment variables control where FreeS/WAN finds its
+diff -Naupr openswan-2.3.0/programs/klipsdebug/klipsdebug.5 openswan-2.3.0-gentoo/programs/klipsdebug/klipsdebug.5
+--- openswan-2.3.0/programs/klipsdebug/klipsdebug.5 2002-04-24 02:35:38.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/klipsdebug/klipsdebug.5 2005-01-20 20:24:20.390145814 -0600
+@@ -103,7 +103,7 @@ full
+ sockets debugging has been set and everything else is not set.
+ .LP
+ .SH FILES
+-/proc/net/ipsec_klipsdebug, /usr/local/bin/ipsec
++/proc/net/ipsec_klipsdebug, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
+ ipsec_spi(8), ipsec_spigrp(8), ipsec_klipsdebug(5), ipsec_version(5),
+diff -Naupr openswan-2.3.0/programs/klipsdebug/klipsdebug.8 openswan-2.3.0-gentoo/programs/klipsdebug/klipsdebug.8
+--- openswan-2.3.0/programs/klipsdebug/klipsdebug.8 2002-04-24 02:35:39.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/klipsdebug/klipsdebug.8 2005-01-20 20:24:20.390145814 -0600
+@@ -117,7 +117,7 @@ turns off only the
+ debugging messages.
+ .LP
+ .SH FILES
+-/proc/net/ipsec_klipsdebug, /usr/local/bin/ipsec
++/proc/net/ipsec_klipsdebug, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
+ ipsec_spi(8), ipsec_spigrp(8), ipsec_klipsdebug(5)
+diff -Naupr openswan-2.3.0/programs/lwdnsq/lwdnsq.xml.in openswan-2.3.0-gentoo/programs/lwdnsq/lwdnsq.xml.in
+--- openswan-2.3.0/programs/lwdnsq/lwdnsq.xml.in 2004-04-03 19:50:56.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/lwdnsq/lwdnsq.xml.in 2005-01-20 20:24:20.390145814 -0600
+@@ -430,7 +430,7 @@ information.
+ <refsect1><title>Special IPSECKEY processing</title>
+
+ <programlisting>
+-/etc/ipsec.d/lwdnsq.conf
++/etc/ipsec/ipsec.d/lwdnsq.conf
+ </programlisting>
+
+ </refsect1>
+diff -Naupr openswan-2.3.0/programs/mailkey/mailkey.in openswan-2.3.0-gentoo/programs/mailkey/mailkey.in
+--- openswan-2.3.0/programs/mailkey/mailkey.in 2003-06-30 00:34:22.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/mailkey/mailkey.in 2005-01-20 20:24:20.391145636 -0600
+@@ -60,7 +60,7 @@ with the following error:
+
+ "$test1st"
+
+-Common concerns: This account must be able to read /etc/ipsec.secrets.
++Common concerns: This account must be able to read /etc/ipsec/ipsec.secrets.
+ If you haven't generated your key yet, please run 'ipsec newhostkey'."
+ exit 0
+ }
+diff -Naupr openswan-2.3.0/programs/pluto/Makefile openswan-2.3.0-gentoo/programs/pluto/Makefile
+--- openswan-2.3.0/programs/pluto/Makefile 2004-12-15 19:27:56.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/pluto/Makefile 2005-01-20 20:24:20.391145636 -0600
+@@ -244,7 +244,7 @@ CPPFLAGS = $(HDRDIRS) $(DEFINES) \
+ -DPOLICYGROUPSDIR=\"${FINALCONFDDIR}/policies\" \
+ -DPERPEERLOGDIR=\"${FINALLOGDIR}/pluto/peer\"
+
+-ALLFLAGS = $(CPPFLAGS) $(CFLAGS)
++ALLFLAGS = $(CPPFLAGS) $(CFLAGS) $(USERCOMPILE)
+
+ # libefence is a free memory allocation debugger
+ # Solaris 2 needs -lsocket -lnsl
+diff -Naupr openswan-2.3.0/programs/setup/Makefile openswan-2.3.0-gentoo/programs/setup/Makefile
+--- openswan-2.3.0/programs/setup/Makefile 2004-04-03 13:44:48.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/setup/Makefile 2005-01-20 20:24:20.391145636 -0600
+@@ -33,25 +33,10 @@ install:: setup
+ @rm -f $(BINDIR)/setup
+ @$(INSTALL) $(INSTBINFLAGS) setup $(RCDIR)/ipsec
+ @ln -s $(FINALRCDIR)/ipsec $(BINDIR)/setup
+- -@for i in 0 1 2 3 4 5 6; do mkdir -p $(RCDIR)/../rc$$i.d; done
+- -@cd $(RCDIR)/../rc0.d && ln -f -s ../init.d/ipsec K76ipsec
+- -@cd $(RCDIR)/../rc1.d && ln -f -s ../init.d/ipsec K76ipsec
+- -@cd $(RCDIR)/../rc2.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc3.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc4.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc5.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc6.d && ln -f -s ../init.d/ipsec K76ipsec
+
+ install_file_list::
+ @echo $(RCDIR)/ipsec
+ @echo $(BINDIR)/setup
+- @echo $(RCDIR)/../rc0.d/K76ipsec
+- @echo $(RCDIR)/../rc1.d/K76ipsec
+- @echo $(RCDIR)/../rc2.d/S47ipsec
+- @echo $(RCDIR)/../rc3.d/S47ipsec
+- @echo $(RCDIR)/../rc4.d/S47ipsec
+- @echo $(RCDIR)/../rc5.d/S47ipsec
+- @echo $(RCDIR)/../rc6.d/K76ipsec
+
+ clean::
+ @rm -f setup
+diff -Naupr openswan-2.3.0/programs/showhostkey/showhostkey.in openswan-2.3.0-gentoo/programs/showhostkey/showhostkey.in
+--- openswan-2.3.0/programs/showhostkey/showhostkey.in 2004-11-14 07:40:41.000000000 -0600
++++ openswan-2.3.0-gentoo/programs/showhostkey/showhostkey.in 2005-01-20 20:24:20.392145458 -0600
+@@ -18,7 +18,7 @@ me="ipsec showhostkey"
+ usage="Usage: $me [--file secrets] [--left] [--right] [--txt gateway] [--id id]
+ [--dhclient] [--ipseckey]"
+
+-file=/etc/ipsec.secrets
++file=/etc/ipsec/ipsec.secrets
+ fmt=""
+ gw=
+ id=
+diff -Naupr openswan-2.3.0/programs/spi/spi.5 openswan-2.3.0-gentoo/programs/spi/spi.5
+--- openswan-2.3.0/programs/spi/spi.5 2002-04-24 02:35:39.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/spi/spi.5 2005-01-20 20:24:20.392145458 -0600
+@@ -162,7 +162,7 @@ since 1 of 8 bits is a parity bit), has
+ 3858 seconds ago and has been idle for 23 seconds.
+ .LP
+ .SH FILES
+-/proc/net/ipsec_spi, /usr/local/bin/ipsec
++/proc/net/ipsec_spi, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(5), ipsec_eroute(5),
+ ipsec_spigrp(5), ipsec_klipsdebug(5), ipsec_spi(8), ipsec_version(5),
+diff -Naupr openswan-2.3.0/programs/spi/spi.8 openswan-2.3.0-gentoo/programs/spi/spi.8
+--- openswan-2.3.0/programs/spi/spi.8 2002-04-24 02:35:40.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/spi/spi.8 2005-01-20 20:24:20.392145458 -0600
+@@ -461,7 +461,7 @@ and protocol
+ (4).
+ .LP
+ .SH FILES
+-/proc/net/ipsec_spi, /usr/local/bin/ipsec
++/proc/net/ipsec_spi, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
+ ipsec_spigrp(8), ipsec_klipsdebug(8), ipsec_spi(5)
+diff -Naupr openswan-2.3.0/programs/spigrp/spigrp.5 openswan-2.3.0-gentoo/programs/spigrp/spigrp.5
+--- openswan-2.3.0/programs/spigrp/spigrp.5 2002-04-24 02:35:40.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/spigrp/spigrp.5 2005-01-20 20:24:20.393145280 -0600
+@@ -77,7 +77,7 @@ be an incoming or outgoing group, depend
+ machine.
+ .LP
+ .SH FILES
+-/proc/net/ipsec_spigrp, /usr/local/bin/ipsec
++/proc/net/ipsec_spigrp, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(5), ipsec_eroute(5),
+ ipsec_spi(5), ipsec_klipsdebug(5), ipsec_spigrp(8), ipsec_version(5),
+diff -Naupr openswan-2.3.0/programs/spigrp/spigrp.8 openswan-2.3.0-gentoo/programs/spigrp/spigrp.8
+--- openswan-2.3.0/programs/spigrp/spigrp.8 2002-04-24 02:35:41.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/spigrp/spigrp.8 2005-01-20 20:24:20.393145280 -0600
+@@ -128,7 +128,7 @@ and finally an AH header to authenticate
+ .BR 0x236 .
+ .LP
+ .SH FILES
+-/proc/net/ipsec_spigrp, /usr/local/bin/ipsec
++/proc/net/ipsec_spigrp, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_tncfg(8), ipsec_eroute(8),
+ ipsec_spi(8), ipsec_klipsdebug(8), ipsec_spigrp(5)
+diff -Naupr openswan-2.3.0/programs/tncfg/tncfg.5 openswan-2.3.0-gentoo/programs/tncfg/tncfg.5
+--- openswan-2.3.0/programs/tncfg/tncfg.5 2002-04-24 02:35:41.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/tncfg/tncfg.5 2005-01-20 20:24:20.393145280 -0600
+@@ -75,7 +75,7 @@ shows that virtual device
+ is not connected to any physical device.
+ .LP
+ .SH "FILES"
+-/proc/net/ipsec_tncfg, /usr/local/bin/ipsec
++/proc/net/ipsec_tncfg, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_eroute(5), ipsec_spi(5),
+ ipsec_spigrp(5), ipsec_klipsdebug(5), ipsec_tncfg(8), ipsec_version(5),
+diff -Naupr openswan-2.3.0/programs/tncfg/tncfg.8 openswan-2.3.0-gentoo/programs/tncfg/tncfg.8
+--- openswan-2.3.0/programs/tncfg/tncfg.8 2002-04-24 02:35:41.000000000 -0500
++++ openswan-2.3.0-gentoo/programs/tncfg/tncfg.8 2005-01-20 20:24:20.394145103 -0600
+@@ -76,7 +76,7 @@ virtual device to the
+ physical device.
+ .LP
+ .SH "FILES"
+-/proc/net/ipsec_tncfg, /usr/local/bin/ipsec
++/proc/net/ipsec_tncfg, /usr/bin/ipsec
+ .SH "SEE ALSO"
+ ipsec(8), ipsec_manual(8), ipsec_eroute(8), ipsec_spi(8),
+ ipsec_spigrp(8), ipsec_klipsdebug(8), ipsec_tncfg(5)