summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch')
-rw-r--r--net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch b/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch
new file mode 100644
index 000000000000..c052b4a189e3
--- /dev/null
+++ b/net-misc/wget/files/wget-1.13.4-openssl-pkg-config.patch
@@ -0,0 +1,30 @@
+detect openssl via pkg-config if it's available
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -234,7 +234,16 @@ dnl
+ dnl Checks for libraries.
+ dnl
+
++PKG_PROG_PKG_CONFIG
++
+ AS_IF([test x"$with_ssl" = xopenssl], [
++ PKG_CHECK_MODULES([OPENSSL], [openssl], [
++ AC_MSG_NOTICE([compiling in support for SSL via OpenSSL])
++ AC_LIBOBJ([openssl])
++ LIBS="$OPENSSL_LIBS $LIBS"
++ CFLAGS="$OPENSSL_CFLAGS -DHAVE_LIBSSL $CFLAGS"
++ ], [
++
+ dnl some versions of openssl use zlib compression
+ AC_CHECK_LIB(z, compress)
+
+@@ -294,6 +303,8 @@ AS_IF([test x$ssl_found != xyes],
+
+ ])
+
++])
++
+ ], [
+ # --with-ssl is not gnutls: check if it's no
+ AS_IF([test x"$with_ssl" != xno], [